Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed Linux Fedora 17 on my new desktop PC, but the default boot ends up with a black screen and no response from the keyboard or mouse. This is after the oval in the centre of the screen fills up and becomes the "curly f" logo. At that point the screen goes blank, and the monitor indicates that it is receiving no input, going into power saving mode.

I can boot up ok if I choose the second entry Fedora Linux on the grub list, shown below, and then everything seems ok -- I am using it to post this question. A couple of error messages flash up before the grub boot choices appear, but are too brief for me to read them.

Here is the content of the grub boot screen:

Fedora (3.9.10.-100.fc17.i686.PAE)
Fedora Linux
Advanced Options for Fedora Linux
Micrsosoft Windows XP Home Edition (on /dev/sda1)

I assume that I should be able to edit grub to make the second entry default -- I have to be pretty snappy to catch it before that action goes ahead, so I would also like to lengthen the pause at the same time. However instructions on the Web for working with grub seem confusing and contradictory.

It seems I should edit my /etc/default/grub file, but I don't understand the various instructions on how to do it, so here it is:

[harry@Harry ~]$ cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Fedora"
GRUB_DEFAULT=saved
GRUB_CMDLINE_LINUX="rd.lvm.lv=vg_harry/lv_swap rd.dm=0 SYSFONT=True rd.md=0  KEYTABLE=uk rd.luks=0 rd.lvm.lv=vg_harry/lv_root LANG=en_US.UTF-8 rhgb quiet"
#GRUB_THEME="/boot/grub2/themes/system/theme.txt"[harry@Harry ~]$ 

I have no problem with booting Windows if I select that option. I need Windoze for some of the electronics related software I use.

Please can anyone help with this? Please don't suggest I go to more up-to-date versions, I work on the principle that "if it works, don't fix it", and I am very happy with Fedora 17, apart from this grub problem; and with using Windoze XP3 when I have to.

share|improve this question
    
Fedora 17 is end-of-life for a while now. Try latest Fedora 20. –  vonbrand Mar 10 at 17:56
    
(Well I did say ...) Thanks @vonbrand, I did try Fedora 20, it was installed by the supplier of the PC, but I found that every yum install I attempted resulted in a stream of lots of "Trying other mirror", or something like that, before giving up, so that I why I installed Fedora 17. However I do also have an F20 DVD, and if you can assure me that I will have no trouble, or, tell me how to avoid it, then I will give it another go. –  Harry Weston Mar 10 at 18:57
    
I can't guarantee you won't have trouble, but for me it went smooth (4 machines up to here). The "trying another mirror" could be due to network problems on your end. A more remote possibility is a messed-up set of local (cache) data, that should be cured by yum clean metadata. If you got handed the PC, maybe it was configured to use local (to the previous owner) mirrors only? –  vonbrand Mar 10 at 19:03
    
Thanks again. Ok -- I believe that this was the first Linux installation the vendor had done. I think that I remember (83 years old, memory fading) that I did try installing F20 myself, no better. In any case I should not have this sort of problem even with F17: I stopped using Fedora 12 only when I switched to this machine, and had no trouble with it except that I could not use a lot of more recent software. –  Harry Weston Mar 10 at 19:14

1 Answer 1

You'll want to change the "GRUB_DEFAULT=saved" to "GRUB_DEFAULT=1" then run grub-install. (I believe, 1 being the second entry since it starts counting at zero.) This means that the second entry will always be the hilighted boot entry when it boots.

However, I agree with other people commenting here, you probably should keep up to date if you want to use Fedora. Every Fedora release is only supported for ~13 months. If you want a similar distro that has longer support, try CentOS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.