Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just installed fedora 20 on my second pc and its running pretty hot, I found a driver on the site http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64.

And i unpack it and i try sh sudo sh amd-driver-installer-13.35.1005-x86.x86_64.run and I get this

Supported adapter detected. Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers for 3.7 release. /lib/modules/3.11.10-301.fc20.i686+PAE/build/include/generated/uapi/linux/version.h cannot be found on this system. One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

and I dont know what to do to het this right i have already tried:

yum install kernel-devel kernel-headers gcc -y

http://www.amd.com/US/PRODUCTS/NOTEBOOK/GRAPHICS/7000M/7400M/Pages/radeon-7400m.aspx

share|improve this question

migrated from stackoverflow.com Mar 9 at 20:58

This question came from our site for professional and enthusiast programmers.

    
I'm interested in the answer to this question as well. Having the same issue. From what I can gather, the person maintaining the catalyst driver package is no longer supporting the driver. kmod-fglrx no longer exists within the rpmfusion repositories. –  John Mar 9 at 16:32

2 Answers 2

Just install the rpmfusion-nonfree repositories [1] and install the driver from that repository:

 yum install kmod-fglrx

[1] http://rpmfusion.org/Configuration

share|improve this answer
1  
This works only through f19. The package is orphaned and no one seems to be planning to adopt. –  Sinthia V May 25 at 0:00

I had the exact same issue. Make sure fedora is completely updated using yum and that issue should go away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.