Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed fedora 20 on my second pc and its running pretty hot, I found a driver on the site http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64.

i unpacked it and i tried sudo sh amd-driver-installer-13.35.1005-x86.x86_64.run and I get this

Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers for 3.7 release./lib/modules/3.11.10-301.fc20.i686+PAE/build/include/generated/uapi/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

and I dont know how to solve it and i have already tried:

yum install kernel-devel kernel-headers gcc -y


share|improve this question

migrated from stackoverflow.com Mar 9 '14 at 20:58

This question came from our site for professional and enthusiast programmers.

I'm interested in the answer to this question as well. Having the same issue. From what I can gather, the person maintaining the catalyst driver package is no longer supporting the driver. kmod-fglrx no longer exists within the rpmfusion repositories. – John Mar 9 '14 at 16:32
You might also try newer Fedora (with F24 right around the corner) to see if improvements in the open source driver help. – mattdm Jun 4 at 15:57

I had the exact same issue. Make sure fedora is completely updated using yum and that issue should go away.

share|improve this answer

Just install the rpmfusion-nonfree repositories [1] and install the driver from that repository:

 yum install kmod-fglrx

[1] http://rpmfusion.org/Configuration

share|improve this answer
This works only through f19. The package is orphaned and no one seems to be planning to adopt. – Sinthia V May 25 '14 at 0:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.