Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using elementary OS (based on Ubuntu 12.04) and yesterday I woke up to no wired ethernet connection. As far as I can remember I changed absolutely nothing, it was working at night and not anymore the next morning.

If I plug in my USB wi-fi antennae it picks it up immediately so it's not my connection/modem. If I start my PC with Ubuntu ethernet works fine so it's not something physically broken.

Here are some outputs:

$ifconfig -a
lo        Link encap:Bucle local  
          Direc. inet:127.0.0.1  Másc:255.0.0.0
          Dirección inet6: ::1/128 Alcance:Anfitrión
          ACTIVO BUCLE FUNCIONANDO  MTU:16436  Métrica:1
          Paquetes RX:2279 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:2279 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:0 
          Bytes RX:201028 (201.0 KB)  TX bytes:201028 (201.0 KB)

wlan0     Link encap:Ethernet  direcciónHW 00:25:9c:a4:32:51  
          Direc. inet:192.168.1.101  Difus.:192.168.1.255  Másc:255.255.255.0
          Dirección inet6: fe80::225:9cff:fea4:3251/64 Alcance:Enlace
          ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:53991 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:43111 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:57986158 (57.9 MB)  TX bytes:16845669 (16.8 MB)


$sudo ethtool eth0
Settings for eth0:
Cannot get device settings: No such device
Cannot get wake-on-lan settings: No such device
Cannot get message level: No such device
Cannot get link status: No such device
No data available

$sudo dhclient eth0
Cannot find device "eth0"

My /etc/network/interfaces file contains:

auto lo
iface lo inet loopback

So there's definitely something wrong with my eth0 settings but I just don't know how it is or how to fix it. Any help will be much appreciated.


Add

Here's the output from sudo lshw -c network -sanitize:

  *-network NO RECLAMADO  
       descripción: Ethernet controller
       producto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabricante: Realtek Semiconductor Co., Ltd.
       id físico: 0
       información del bus: pci@0000:04:00.0
       versión: 06
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list
       configuración: latency=0
       recursos: ioport:d000(size=256) memoria:d0004000-d0004fff memoria:d0000000-d0003fff
  *-network
       descripción: Interfaz inalámbrica
       id físico: 1
       información del bus: usb@1:5
       nombre lógico: wlan0
       serie: [REMOVED]
       capacidades: ethernet physical wireless
       configuración: broadcast=yes driver=rt2800usb driverversion=3.2.0-60-generic-pae firmware=0.29 ip=[REMOVED] link=yes multicast=yes wireless=IEEE 802.11bg

where "NO RECLAMADO" means "NOT CLAIMED".

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I would start at the bottom of the stack and confirm that the Ethernet device is actually getting detected by the OS first.

Example

$ sudo lshw -c network -sanitize
  *-network               
       description: Ethernet interface
       product: 82577LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: em1
       version: 06
       serial: [REMOVED]
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.12-1 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:43 memory:f2600000-f261ffff memory:f2625000-f2625fff ioport:1820(size=32)

From this type of output you can start to confirm that there is an actual driver attached to your Ethernet device and that's at least getting detected by the kernel during boot.

UPDATE #1

Based on this output from your updates:

$ sudo lshw -c network -sanitize:
  *-network NO RECLAMADO  
       descripción: Ethernet controller
       producto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        ...
       fabricante: Realtek Semiconductor Co., Ltd.
       id físico: 0
       información del bus: pci@0000:04:00.0
       versión: 06
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list
       configuración: latency=0
       recursos: ioport:d000(size=256) memoria:d0004000-d0004fff memoria:d0000000-d0003fff

You should notice that the "configuration" line doesn't specify a kernel module (driver). This is likely your issue.

I did find this thread which sounds related to your issue (even though it's with Ubuntu). The thread is titled: "Thread: 13.10 RTL8111/8168/8411 slow internet". I'd try loading this module to see if it'll work with your particular hardware:

 $ sudo modprobe r8169

You can check the output of dmesg afterwards to see if the module loaded successfully.

If this works you can make it permanent by adding this module to you system's list of modules to load at bootup.

 $ sudo echo "r8169" >> /etc/modules

You could also add an association in the /etc/modprobe.d/ directory which would associate the device, r6168 with the r6169.

share|improve this answer
    
Hi slm, thanks for the answer. Please see the updated question, I've added the output of the command you mentioned. There's clearly an issue there but I'm not sure what it is. Is my driver not installed? –  Gabriel Mar 9 at 21:13
    
@Gabriel - if you notice in the output that the Ethernet device does not have a kernel module (driver) assigned to it. This is likely the issue. This would show up in the configuration line if you had a driver assigned. –  slm Mar 10 at 1:19
    
@Gabriel - looks to be the same card: askubuntu.com/questions/396804/… –  slm Mar 10 at 1:20
    
the line sudo modprobe r8169 effectively activates the ethernet connection. Any idea why I have to type this command each time I turn on my system? –  Gabriel Mar 11 at 1:40
    
@Gabriel - Your system isn't able to automatically associate/detect this Ethernet device as being able to work with that driver. You could either add it to /etc/modules or make a file under /etc/modprobe.d/ which will load this driver, associating it to the device you have. –  slm Mar 11 at 1:48
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.