Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Whenever I run linux on many ARM based systems, I see a message like this:

Starting Bootlog daemon: bootlogd.

As can be seen from the log messages below, it takes some finite time, close to 0.5 seconds. Can I stop this opeation from executing, so as to save this time? What changes will be required in Kerenel configuration (may be using menu config or something similar) to make sure that this operation never comes while booting?

Thu Feb 06 18:05:34.660 2014] 
[Thu Feb 06 18:05:34.660 2014] 
[Thu Feb 06 18:05:34.660 2014] U-Boot 2013.07 (Feb 04 2014 - 14:41:40)
[Thu Feb 06 18:05:34.660 2014] 
[Thu Feb 06 18:05:34.660 2014] Memory: ECC disabled
[Thu Feb 06 18:05:34.660 2014] DRAM:  1 GiB
[Thu Feb 06 18:05:34.677 2014] MMC:   zynq_sdhci: 0
[Thu Feb 06 18:05:34.677 2014] SF: Detected N25Q128A with page size 64 KiB, total 16 MiB
[Thu Feb 06 18:05:34.708 2014] *** Warning - bad CRC, using default environment
[Thu Feb 06 18:05:34.708 2014] 
[Thu Feb 06 18:05:34.708 2014] In:    serial
[Thu Feb 06 18:05:34.708 2014] Out:   serial
[Thu Feb 06 18:05:34.708 2014] Err:   serial
[Thu Feb 06 18:05:34.708 2014] U-BOOT for Xilinx-ZC702-14.7
[Thu Feb 06 18:05:34.708 2014] 
[Thu Feb 06 18:05:34.708 2014] 
[Thu Feb 06 18:05:34.708 2014] SF: Detected N25Q128A with page size 64 KiB, total 16 MiB
[Thu Feb 06 18:05:36.285 2014] SF: 11010048 bytes @ 0x520000 Read: OK
[Thu Feb 06 18:05:36.285 2014] ## Loading kernel from FIT Image at 01000000 ...
[Thu Feb 06 18:05:36.285 2014]    Using 'conf@1' configuration
[Thu Feb 06 18:05:36.285 2014]    Trying 'kernel@1' kernel subimage
[Thu Feb 06 18:05:36.285 2014]      Description:  PetaLinux Kernel
[Thu Feb 06 18:05:36.285 2014]      Type:         Kernel Image
[Thu Feb 06 18:05:36.285 2014]      Compression:  gzip compressed
[Thu Feb 06 18:05:36.285 2014]      Data Start:   0x010000f0
[Thu Feb 06 18:05:36.285 2014]      Data Size:    4997719 Bytes = 4.8 MiB
[Thu Feb 06 18:05:36.285 2014]      Architecture: ARM
[Thu Feb 06 18:05:36.285 2014]      OS:           Linux
[Thu Feb 06 18:05:36.285 2014]      Load Address: 0x00008000
[Thu Feb 06 18:05:36.285 2014]      Entry Point:  0x00008000
[Thu Feb 06 18:05:36.285 2014]      Hash algo:    crc32
[Thu Feb 06 18:05:36.285 2014]      Hash value:   db7d8248
[Thu Feb 06 18:05:36.285 2014]    Verifying Hash Integrity ... crc32+ OK
[Thu Feb 06 18:05:36.383 2014] ## Loading fdt from FIT Image at 01000000 ...
[Thu Feb 06 18:05:36.383 2014]    Using 'conf@1' configuration
[Thu Feb 06 18:05:36.383 2014]    Trying 'fdt@1' fdt subimage
[Thu Feb 06 18:05:36.383 2014]      Description:  Flattened Device Tree blob
[Thu Feb 06 18:05:36.383 2014]      Type:         Flat Device Tree
[Thu Feb 06 18:05:36.383 2014]      Compression:  uncompressed
[Thu Feb 06 18:05:36.383 2014]      Data Start:   0x014c442c
[Thu Feb 06 18:05:36.383 2014]      Data Size:    11161 Bytes = 10.9 KiB
[Thu Feb 06 18:05:36.383 2014]      Architecture: ARM
[Thu Feb 06 18:05:36.383 2014]      Hash algo:    crc32
[Thu Feb 06 18:05:36.383 2014]      Hash value:   8aee0d02
[Thu Feb 06 18:05:36.383 2014]      Hash algo:    sha1
[Thu Feb 06 18:05:36.383 2014]      Hash value:   266e39ed71a93229a26f0cf7e9f5317b64c2e407
[Thu Feb 06 18:05:36.383 2014]    Verifying Hash Integrity ... crc32+ sha1+ OK
[Thu Feb 06 18:05:36.387 2014]    Booting using the fdt blob at 0x14c442c
[Thu Feb 06 18:05:36.387 2014]    Uncompressing Kernel Image ... OK
[Thu Feb 06 18:05:36.782 2014]    Loading Device Tree to 07ffa000, end 07fffb98 ... OK
[Thu Feb 06 18:05:36.782 2014] 
[Thu Feb 06 18:05:36.782 2014] Starting kernel ...
[Thu Feb 06 18:05:36.782 2014] 
[Thu Feb 06 18:05:37.570 2014] INIT: version 2.88 booting
[Thu Feb 06 18:05:37.867 2014] Starting Bootlog daemon: bootlogd.
[Thu Feb 06 18:05:37.910 2014] Creating /dev/flash/* device nodes

.
.
share|improve this question
    
Actually from this output there is 0.043 seconds between the bootlogd message and the next one. –  Graeme Mar 8 at 10:38

1 Answer 1

It's part of your init scripts. You could disable it there. Or if this is a Debian-like system, you could remove the bootlogd package.

Of course, you'll lose the boot logs, which can be quite valuable in figuring out what went wrong, especially if the system doesn't normally have a console on it.

But I doubt its really taking nearly as long as you think. Most likely, the time is actually being taken by the init system, loading the shell, the libraries it depends on, etc. Or possibly a few scripts running without spitting out messages; look in /etc/rcS.d and see if bootlogd is the first thing.

share|improve this answer
    
Thanks. Do you think if I remove this process from init, I would not be able to see the messages I posted above? Also if the bootlog is finished (see teh second last line in the log above), then how the rest of the messages are being printed( eg Creating /dev/flash/* device nodes.. and so on )? –  gpuguy Mar 8 at 6:54
    
@gpuguy You'd see the messages on the console (if your device has one... could be a HDMI out, could be a LCD, could be a serial port. No idea what your device has). But they wouldn't be saved anywhere. –  derobert Mar 8 at 6:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.