Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to create a wifi hotspot in gnome shell and Arch Linux. I open "System Settings" > "Network", then I select "wifi" on the LH side and click "Use as Hotspot..." on the bottom.

The system tells that the hotspot is on, shows me the SSID, Security Type (WEP only) and a security key. It does not allow me to configure (there's no configure option). Also the hot spot seems actually not being avaiable. If I try to scan for hotspots by any other device, the hotspot is not found and by manually inserting SSID, WEP and password it doesn't work too.

I used to do without problems in Ubuntu, so my feeling is that I'm missing some dependencies and/or configuration in Arch Linux.

EDIT: I made little progress by installing modemmanager and enabling it

sudo systemctl start ModemManager.service && sudo systemctl enable ModemManager.service

Now the hotspot starts and divices can connect to it. However there's still no configuration available for the hotspot (i.e. change name, wep etc) and also I noticed that if running some web services on host (hot spot host) consumed by connected devices, not always works as expected and give errors.

I guess I'm still missing something to make it complete and working 100%. Any hints?

share|improve this question
    
try sudo nm-connection-editor to configure :-) –  OSaad Apr 21 at 19:37

1 Answer 1

up vote 2 down vote accepted

I fixed by installing modemmanager and enabling it

sudo systemctl start ModemManager.service && sudo systemctl enable ModemManager.service

Now the hotspot starts and divices can connect to it. However there's still no configuration available for the hotspot (i.e. change name, wep etc).

Initially it was working but still a little buggy especially with virtualbox and webservices... however I just got a systemd update few minutes ago and now everything seems to be working well and fast.

During my attempts I aslo installed and enabled wpa_supplicant.service but I'm not sure it is actually required (I'll try to disable it to check).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.