Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I have created a simply vhost on Lighttpd web server and put these lines on the .conf file.

server.errorlog                = "/var/log/lighttpd/error.log"
accesslog.filename             = "/var/log/lighttpd/access.log"

I have read error.log and I found this:

2011-04-22 00:36:58: (server.c.954) WARNING: unknown config-key: accesslog.filename (ignored)

How is it possible? accesslog.filename exists, it's an option of the server.

I found it on their website:

What can I do?

share|improve this question

1 Answer 1

The option accesslog.filename is for the mod_accesslog module, so you need to load that module.

server.modules += ( "mod_accesslog" )
share|improve this answer
Appreciated too! I was googling for this just a minute ago. – shevy Aug 22 '14 at 19:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.