Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Using the less paginator, you can use the -r option to properly display colored input and the -S option to disable line wrap.

However, when using less -rS or equivalently less -r -S, colors are diplayed but lines are wrapped. How can this be achieved?

share|improve this question
2  
Specifying -R instead of -r might work for you. –  devnull Mar 3 '14 at 8:36

1 Answer 1

up vote 8 down vote accepted

If the -r option doesn't work, maybe the -R option will do what you want:

-R or --RAW-CONTROL-CHARS

Like -r, but only ANSI "color" escape sequences are output in "raw" form. Unlike -r, the screen appearance is maintained correctly in most cases. ANSI "color" escape sequences are sequences of the form:

ESC [ ... m

where the "..." is zero or more color specification characters For the purpose of keeping track of screen appearance, ANSI color escape sequences are assumed to not move the cursor. You can make less think that characters other than "m" can end ANSI color escape sequences by setting the environment variable LESSANSIENDCHARS to the list of characters which can end a color escape sequence. And you can make less think that characters other than the standard ones may appear between the ESC and the m by setting the environment variable LESSANSIMIDCHARS to the list of characters which can appear.

share|improve this answer
    
Thank you! Actually this was meant to be a self-answered question (after a while I figured this out and wanted to share), but I've got too few reputation and -after letting me write the answer- it said I should wait 8 hours before posting... Never mind, my answer looked exately like yours –  Davide Mar 3 '14 at 10:08
1  
As a side-note, this is similar to what git does: by default it uses less as its pager and invokes it with LESS=FRSX in the environment (just like less -FRSX) –  Davide Mar 3 '14 at 10:14
    
@Davide, that's interesting about git, I always wondered why it behaved differently, never got around to investigating though. Thanks. –  Graeme Mar 3 '14 at 10:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.