Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having an issue. I'm trying to install Gentoo in virtualbox. I can't use nano because when I press Ctrl + x, I see, I have written x letter. Something's wrong with Ctrl key in virtualbox. I've seen similar question, but the answer doesn't work to me. Any ideas?

share|improve this question
    
Are you using the right Ctrl key or the left - I think the right one is automatically designated as the 'host' key –  Wilf Mar 2 at 22:56
    
@Wilf Left ctrl key. I know about 'host' key. –  enedil Mar 2 at 23:08
    
VirtualBox is rather buggy, but left+control has always worked for me. As one example of VB's buggyness, its host-only network adapter randomly just stops working in Windows. Closer to the OP, my right alt+letter combinations to get non-English accents like ñ sometimes, but not always, do not work in other Windows apps while I’m running VirtualBox. –  samiam Mar 3 at 9:28
    
Have you tried installing the VirtualBox addons? They always seem to solve mouse and keyboard related issues like these for me. –  Chirag64 Jun 2 at 14:11

1 Answer 1

up vote 2 down vote accepted

After a LOT of research I found that it was a misconfiguration in my Gnome desktop settings of my host machine. I had a feature turned on which intercepted my control keys (left and right) and displayed a sort of animated bulls-eye on the cursor when either is pressed. The trouble with that accessibility feature is that it doesn't pass the control key on to any programs.

The solution was to turn it off.  To do so from Linux Mint 13 Maya (MATE) do the following:
1 - Click on the Menu button on the lower left corner of the screen.
2 - Click on Preferences
3 - Click on Assistive Technologies
4 - Click on Mouse Accessibility
5 - Click on the General tab
6 - Under Locate Pointer, uncheck the box that says "Show position of pointer when the Control key is pressed".

I'm attaching a screen shot with all those menus displayed, and the relevant check box circled in red. enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.