Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've changed my login shell to zsh from bash on an installation of Debian Squeeze with XFCE. When I launch xfce4-terminal, zsh starts but does not load my configuration. I have searched high and low, but have come to SO to extend beyond my regular limits and see if someone can assist in diagnosing this.

share|improve this question

migrated from stackoverflow.com Apr 21 '11 at 14:27

This question came from our site for professional and enthusiast programmers.

1  
You'll have to give more information. What configuration is not being loaded? Do you get different behavior from zsh in different circumstances on the same machine? Do you have a .zshrc? Post the output of ps $$; echo $ZSH_VERSION; ls -l ~/.zshrc in that XFCE terminal. –  Gilles Apr 19 '11 at 21:28
    
@Gilles - I do have a .zshrc file. ZSH loads fine on a TTY or when I manually run zsh. I'll get output later this evening. –  Larry G. Wapnitsky Apr 20 '11 at 12:25
    
@Gilles - Oddly, it started working last night after a reboot (which I had done already). –  Larry G. Wapnitsky Apr 21 '11 at 10:24
1  
You probably put your settings in .zprofile or .zlogin. Short answer: you should put your settings in .zshrc or .zshenv instead. –  Mikel Apr 23 '11 at 3:37
    
@Mikel - they were in .zshrc –  Larry G. Wapnitsky Apr 26 '11 at 13:08
add comment

1 Answer 1

You changed the shell in your user profile, but since you were already logged in your environment variables had already been set and xfce4-terminal was assuming you would want to use whatever was set as your shell when the environment got initiated. If you had logged out of everything on the machine or authenticated another way like logging in with SSH, it would have worked as well.

Many terminal programs have their own preferences for what shell to launch in them. These preferences can use any program you are allowed to run as the shell, including any system authorized shells. When you authenticate against the system, the first thing it will give you is always the shell in your profile, but after that you are free to run whatever.

share|improve this answer
    
I had rebooted previously with little effect. The one magic reboot and all was working and has been since. –  Larry G. Wapnitsky Apr 26 '11 at 13:08
1  
In the unix world there isn't a magic reboot, one isn't different from another. Something else had to have changed in between times for the last one have the expected effect. –  Caleb Apr 26 '11 at 13:14
    
yeah, i know, but i changed nothing. –  Larry G. Wapnitsky Apr 26 '11 at 15:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.