Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In the process of building one library (Webdriver) I got the following error:

Package ibus-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `ibus-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'ibus-1.0' found

It seems to be because of the following line in source code of Webdriver:

pkg-config ibus-1.0 --libs

that produces the same output when I run it.

So I installed ibus using installation instructions from its website:

sudo apt-get install ibus ibus-clutter ibus-gtk ibus-gtk3 ibus-qt4

But I still get the same output after invoking pkg-config ibus-1.0 --libs. Should I install ibus 1.0 to build that library? If yes, where can I find it? It doesn't seem to be present in ibus's downloads list?

My OS is Ubuntu 13.04

share|improve this question
up vote 5 down vote accepted

If you need it for a build, then you need the #include headers as well. These, and the pkgconfig files, are not in the normal packages because they don't serve any purpose outside of compiling. Instead, they are included in seperate -dev packages which you can install if you want to build something which must be compiled against whatever library.

It looks to me (on Debian) like the package you want is libibus-1.0-dev.

share|improve this answer
I've so far been unable to locate the ibus lib headers packaged for RHEL/OEL. – javabrett May 24 '15 at 23:13
@javabrett Try yum provides "*/ibus-1.0.pc". – goldilocks May 25 '15 at 8:05
Thanks, that is helpful, yum provides "*/ibus*" yields ibus-devel-1.3.4-6.el6.x86_64. – javabrett May 25 '15 at 9:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.