Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

this is my first attempt to install Arch Linux on my Dell XPS 13 (L322X) laptop in UEFI mode. I've dowloaded "archlinux-2014.02.01-dual.iso" and written to my USB pen drive with the dd way. I boot my laptop with the usb pen drive in my LH side USB port (RH side won't recognize the system), press F12 while loading and I select USB from the UEFI boot menu list. The bootloader menu appears and I select "Arch Linux archiso x86_64 UEFI CD", the screen gets black, the usb pen drive led flashes a few times and then the system gets stuck there. Nothing happens... I can only press the power button to power off the laptop. I've tried also with a different usb pen drive and with unetbootin instead of dd but I get the same result.

Note: On that laptop I sucessfully booted (and installed) Ubuntu in UEFI mode in the past.

Note: if I boot the arch installation media in legacy way from the same usb pen drive, I successfully get to command prompt

EDIT: after many attempts I decided to try the previous installer iso "archlinux-2014.01.05-dual.iso". This one works also in UEFI mode (I used unetbootin to "burn" it to my usb pend drive). So my feeling is that current iso (archlinux-2014.02.01-dual.iso) has some issues with UEFI. I've filed a bug report on Arch bug tracker

share|improve this question
up vote 0 down vote accepted

after many attempts I decided to try the previous installer iso "archlinux-2014.01.05-dual.iso". This one works also in UEFI mode (I used unetbootin to "burn" it to my usb pend drive). So my feeling is that current iso (archlinux-2014.02.01-dual.iso) has some issues with UEFI. I've filed a bug report on Arch bug tracker

share|improve this answer
    
This is a bug with the kernel and EFIstub loading, not necessarily that particular ISO (only insofar as it contains a specific kernel, anyway). This has been apperaring sporadically since 3.7.x... – jasonwryan Feb 28 '14 at 18:57

In case this happens again for no reason, you could try to add the nomodeset option at boot (add it anywhere, after/before/between the quiet splash). It prevents the system to re-scale your resolution, which from my experience is buggy on my computer and prevents the OS to load.

Plus, since you've installed this as UEFI, double check the type of USB key you're making (at least under Windows, I wouldn't know how to chose it under Linux). GPT for UEFI is what you need in any case, if you're trying to install a system as UEFI.

This trick is resolving the boot problem from USB, once the system is installed you can boot your OS without this option, thus having your native resolution just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.