Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have set up the NoMachine NX server on a virtual machine running on a server in my datacenter to use for keeping applications running and connecting/disconnecting from them via my laptop. The problem is, applications I run on there are kinda... ugly!

This is what Firefox looks like when running it through NoMachine: NX Screenshot

And this is how it looks when running directly in the VMware console: Direct Screenshot

How can I change how applications look when using NoMachine NX?

EDIT: I am starting the NX session using custom desktop settings. I have selected "Run the console" as the Application and "Floating Window" under the "custom desktop" settings under the "Configure..." screen:

Configure screen Custom Settings Screenshot

share|improve this question
    
How do you start the NX session? You're clearly running Gnome with the Ubuntu theme in VMware, and either not running Gnome or with a different theme in NX. –  Gilles Apr 20 '11 at 23:50
    
+1 for showing us exactly what you want. –  pdo Apr 21 '11 at 11:37
    
@Gilles: Yeah I guess that's my question is how to run Gnome over NX. I am starting the console in a rootless session. I will post a screenshot showing details. –  Josh Apr 21 '11 at 12:23
    
I'm just an nx user who saw this and thought it looked weird that NX is not showing the remote desktop how you have set it to look. What theme have you set on the Gnome desktop? I don't know what VMware is capable of but NX will simply show you a replica of the desktop on the server. Have you tried contacting them or checking their website? –  user6839 Apr 21 '11 at 19:02
    
@NXer I'm using a rootless NX session, not a "VNC-style" one –  Josh Apr 21 '11 at 19:25

2 Answers 2

up vote 3 down vote accepted

I figured this one out by examining ps awwwwx|grep gnome after logging in normally. I needed to start /usr/lib/gnome-settings-deamon/gnome-settings-daemon on the remote machine.

So I created a small shell script:

#!/bin/bash

/usr/lib/gnome-settings-deamon/gnome-settings-daemon
gnome-terminal&
nautilus --no-desktop&
gnome-panel

I set this as the command to run in the NoMachine's "custom" settings box, and now all my windows are themed properly!

share|improve this answer

NX does not change the theme of your remote desktop setting. It will render to the local client what it picks up on the remote desktop.NX’s goal is to permit users to run, over the Internet, the same colourful and graphic intensive applications that run on their desktop computers.

You have obviously set Gnome differently on your remote virtual desktop environment. Check your settings and theme on your remote environment and set them to what you want to them to be and NX will show you those next time you connect.

NXer

share|improve this answer
    
Do you mean I need to change the settings for my local gnome theme? If so then I need to ask a different question. I'll do some tests and see if the applications look different using different local systems... –  Josh Apr 21 '11 at 12:30
    
No, that doesn't make sense, because on my laptop I have a custom Gnome theme and that theme is not used when running applications through NX... So, I'm sorry, what are you suggesting I do? –  Josh Apr 21 '11 at 12:33
    
My hunch is that Firefox tries to detect whether it's running in Gnome or not, and makes itself look different if it is. Try choosing "new virtual desktop" and "run the default X client script" and see if that makes any difference. –  Robin Green Apr 21 '11 at 17:41
1  
Welcome to Stack Exchange. Note that you must explicitly disclose your affiliation. Your answer reads more like ad copy than like a useful contribution to solve a technical problem. For example, it would be helpful if you explained how NX starts a session (for VNC, I'd point Josh towards ~/.vnc/xstartup; does NX have anything in the same vein?). –  Gilles Apr 21 '11 at 18:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.