Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I find some questions talking about disabling xscreensaver with flash but no one about HTML5. Then, how to disable xscreensaver when firefox is playing an HTML5 vidieo and, if possible, only for some domain?

share|improve this question
    
It's related to your plugin and add-on in your firefox, check them and disable some them. –  PersianGulf Feb 27 '14 at 9:07
1  
I haven’t install any plug-in or add-on to watch videos with Firefox. I see videos with the default settings. I talk about videos in HTML5. –  fauve Feb 27 '14 at 10:01
    
So you talk about your GNU\Linux, explain me Xscreensaver or gnome screen saver or KDE screen saver? –  PersianGulf Feb 27 '14 at 11:53
    
Yes, my distribution is Gentoo. I use Xscreensaver to lock my screen. I configure Xscreensaver to autolock every 5min. Then I would like disable autolocking when a video is played by Firefox. For example, I can do this with mplayer with the line heartbeat-cmd="xscreensaver-command -deactivate" in the ~/.mplayer/config. –  fauve Feb 27 '14 at 20:43

1 Answer 1

You can write it in your ~/mplayer/config : stop-xscreensaver=1

And remove the following line:

heartbeat-cmd="xscreensaver-command -deactivate"
share|improve this answer
    
It doesn’t work with my mplayer. But, with the old command it work fine. Anyway, I haven’t any problem with mplayer; I have problem only with firefox. –  fauve Feb 28 '14 at 0:15
    
you can use pid=`ps ax |egrep xscreensaver |awk {'print $1'}` ; kill $pid; you should put the above code in the rc.local –  PersianGulf Feb 28 '14 at 1:59
    
Hmm… it isn’t a god idea because you kill xscreensaver. I was searching a way like the tip for mplayer: xscreensaver stay runing but didn’t autolock; then when mplayer is playing a video and I run xscreensaver-command -lock I can lock my screen. And when I close mplayer xscreensaver recover his normal way. Thank you Mohsen, I see you try to help me but it isn’t exactly what I was searching ☺ –  fauve Feb 28 '14 at 4:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.