Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When using the interactive mode of the restore utility to restore backups made with dump UTF-8-encoded filenames doesn't display correctly, see example below. The ??s should be ös ...

$ sudo restore -if dumpfile
Dump tape is compressed.
restore > ls
./somedir:
lagerl??fSelma_k??rkarlen.txt

restore >

How come? What are the solutions do this problem?

The dump and the restore are performed on the same machine, that has the locale set as follows:

$ locale
LANG=sv_SE.UTF-8
LANGUAGE=sv:en_US:en
share|improve this question
    
may be you use old dump package. –  Mohsen Pahlevanzadeh Feb 24 at 22:31
    
Thanks, I believe I'm using the latest version dump 0.4b44 (using libext2fs 1.42.8 of 20-Jun-2013). –  PetaspeedBeaver Feb 24 at 23:22

1 Answer 1

up vote 1 down vote accepted

The source code has this:

for (cp = fp->fname; *cp; cp++)
    if (!vflag && (*cp < ' ' || *cp >= 0177))
        *cp = '?';

So it looks like it will substitute '?' for non-printable-ASCII characters unless you give restore the -v option or, in interactive mode, type the verbose command.

share|improve this answer
    
Confirmed, this fixes the issue. Thank you! –  PetaspeedBeaver Feb 25 at 11:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.