Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I tried to make && make install package, but I get an error:

libX11.so.6 not found

Where can i get this lib?

share|improve this question
    
You probably don't have X11 Installed. Which OS? Which Package? –  radius Aug 24 '10 at 5:47
    
OS - fedora 13. package GPicView –  shk Aug 24 '10 at 6:03
add comment

2 Answers

up vote 6 down vote accepted

You need to install the libX11 package:

$ rpm -qf /usr/lib/libX11.so.6
libX11-1.3.1-3.fc13.i686

Just go

$ yum -y install libX11  

One more thing though: if you don't know how to find and install a library package, care to share why you are trying to compile a piece of software that is officially packaged for Fedora 13 in the most recent version?

$ yum info gpicview
Available Packages
Name        : gpicview
Arch        : x86_64
Version     : 0.2.1
Release     : 3.fc13
Size        : 93 k
Repo        : fedora
Summary     : Simple and fast Image Viewer for X
URL         : http://lxde.sourceforge.net/gpicview/
License     : GPLv2+
Description : Gpicview is an simple and image viewer with a simple and intuitive interface.
            : It's extremely lightweight and fast with low memory usage. This makes it
            : very suitable as default image viewer of desktop system. Although it is
            : developed as the primary image viewer of LXDE, the Lightweight X11 Desktop
            : Environment, it only requires GTK+ and can be used in any desktop environment.
share|improve this answer
add comment

I bet a more appropriate response would be to install libX11-devel...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.