Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a HP laptop with Intel Centrino 2230 N card. The system is Xubuntu 13. Wi-Fi works on and off. When it's down, it still connects to the network and obtains an IP address, but ping to the gateway doesn't work. The network has WPA2. Setting wlan0 down and up doesn't help.

Windows Wi-Fi on the same laptop works fine, so it's an issue with the Linux configuration. Also, the access point (TP-Link) works fine with a Mac.

EDIT: N mode is disabled because it was slow.

Any idea on how to fix it? Here's some diagnostic output:

$ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"xxxxx"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: D8:5D:4C:xx:xx:xx   
          Bit Rate=2 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=58/70  Signal level=-52 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:28   Missed beacon:0


$ ip addr sh
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether a0:b3:cc:49:e3:50 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 84:a6:c8:82:3c:ff brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.100/24 brd 192.168.1.255 scope global wlan0
       valid_lft forever preferred_lft forever


$ ip link sh
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether a0:b3:cc:49:e3:50 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT qlen 1000
    link/ether 84:a6:c8:82:3c:ff brd ff:ff:ff:ff:ff:ff
share|improve this question
add comment

1 Answer 1

This is a bit of my opinion but I've had lots of problems with the Intel Centrino 1000-N and 2000-N families of cards under a variety of Linuxes. The solution that has generally made them work best has been to disable the wireless-N feature of the card/driver and use it purely as a G card exclusively.

You can do so when you load the iwlagn kernel module.

Example

$ sudo rmmod iwlagn
$ sudo modprobe iwlagn 11n_disable=1

You can make this permanent like so:

# /etc/modprobe.d/wireless.conf
options iwlagn 11n_disable=1

Then do the same unload/reload of the module.

$ sudo rmmod iwlagn
$ sudo modprobe iwlagn

References

share|improve this answer
    
Yes, I already disabled N mode a while ago because it was very slow. I believe the card is using iwlwifi + iwldvm modules. Removing and inserting them doesn't help. –  user1123466 Feb 20 at 19:54
    
@user1123466 - I would encourage you to try a different distro to see if the problem persists. Wireless issues are notoriously difficult to ferret out and there are a number of places where bugs in either drivers or in the software in the higher levels in the stack can cause problems. This is meant only to further debug your issue, not as a long term solution! –  slm Feb 20 at 20:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.