Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've got a Linux box running SLES11SP1 with 4 NVIDIA GPUs in it, for running CUDA programs.

If the GPU is accessed by a process running as root, it changes the permissions on /dev/nvidia{0,1,2,3,ctl} to something inaccessible by non-root users. However, this behavior doesn't seem to occur when running on Ubuntu.

Does anybody know what would cause this behavior on SLES, and how to disable it?

share|improve this question
    
Are you specifically running a program as root? –  penguin359 Apr 20 '11 at 1:13
    
@penguin359 - Sometimes I do specifically run a program as root that needs to access the GPUs. When this happens, the permissions are changed. –  Lorin Hochstein Apr 20 '11 at 14:12

1 Answer 1

up vote 2 down vote accepted

Had same issue on SLES11sp1. Only way I could resolve it was to add the LDAP user account to the local machine's video group. I was told you could also change a line in /etc/modprobe.d/50-nvidia.conf from NVreg_DeviceFileMode=0660 to NVreg_DeviceFileMode=0666.

share|improve this answer
    
Setting NVreg_DeviceFileMode=0666 seems to have done the trick. –  Lorin Hochstein May 13 '11 at 3:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.