Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So currently I am getting the 403 forbidden error. I have tried everything that I could possible think of. It was working a couple of days ago however it has stopped working now. I have tried everything from adding:

Order Allow,Deny
Allow from all
Require all granted

Which is on all of my vhosts. Also I have tried chmod +x each of the sites main directory. So right now I am stumped, I have looked everywhere trying to figure out why it is happening.

AH01630: client denied by server configuration:

Is what I am getting on every attempt to access one of the sites. I'm guessing this is what I expect from using an old PPC G5 mac as a server running YDL which I went ahead and compiled everything from source myself -.-

share|improve this question

migrated from serverfault.com Feb 18 at 21:30

This question came from our site for system and network administrators.

3  
Did you try checking the error log? –  Michael Hampton Feb 18 at 21:29
    
Might be a dumb question, but you restarted Apache after changing the configuration, right? –  Chris S Feb 18 at 21:30
    
Try to su to the apache user and attempt to cd to the directories in question or open one of the files in vi. If you're being blocked by file system permissions somewhere, that should help. Also check for SELinux (does YDL ship with SELinux?) –  Safado Feb 18 at 21:36
    
Firstly, quite clearly I have checked the error log since I mentioned it in the post, I have restarted apache. And when trying to su to the apache yeser i get This account is currently not available. –  Howelley Feb 18 at 22:03

2 Answers 2

up vote 1 down vote accepted

I recently ran into this issue with an Alias entry I was using to include a directory into my server configuration. I resolved the issue by sym-linking the directory into the correct place in the directory tree.

Do check the error log.

Some Linux distribution run the web server as www-data. Verify which id is used and sudo to that account to check directory permissions. It can help to have a file in the directory you can try to retrieve in case directory indexing is disabled.

share|improve this answer
    
Thanks this worked, strange though... I basically copied a virtualhost config from my test server to my ydl home server which worked fine on the test server but clearly not on my home server. Probably because my home 2.4 and the other is 2.2 –  Howelley Feb 18 at 23:05
    
Yes, I was upgrading to 2.4 when this happened. Only one Alais failed. –  BillThor Feb 18 at 23:12

Check SElinux. That could be the culprit. To disable:

$ sudo setenforce 0

You can also disable it via this file:

/etc/sysconfig/selinux 

Change the value from enforced to disabled.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Anthon Feb 19 at 11:26
    
Disable selinux and check simply execute #setenforce 0 and also update the file /etc/sysconfig/selinux enforced to disabled –  user1365171 Feb 19 at 11:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.