Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Dell latitude 6430u which has three tactile keys for mute/audio decrease/audio increase.

On debian (sid), either with xfce or gnome, these keys don't work well. The mute key has never work. The two others work sometimes, but not well (I have to press twice, sometimes nothing happens, ...)

Is it possible to have a better support for these keys? I don't know anything about drivers for tactile keys.

When I use xev and using this shortcut I've got:

FocusOut event, serial 37, synthetic NO, window 0x4c00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 37, synthetic NO, window 0x4c00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

FocusOut event, serial 37, synthetic NO, window 0x4c00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 37, synthetic NO, window 0x4c00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
share|improve this question

1 Answer 1

If you're using Gnome the easiest way is to run gnome-keybinding-properties (System > Preferences > Keyboard Shortcuts)

Instead of typing a shortcut such as Ctrl+M, hit the button on your keyboard. Type in the command below for the 'Mute' key:

amixer sset Master toggle

Volume Up:

amixer -c 0 set Master 1+ unmute

Volume Down:

amixer -c 0 set Master 1-

Of course if that is increasing or decreasing the volume too slowly you can change the number in front of the + or - sign.

share|improve this answer
1  
The problem is these keys are not properly recognized. They work sometimes, so I don't need to tell them what to do (increase/decrease). I guess it's a driver problem not a key assignment one. –  ppr Feb 24 at 11:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.