Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a current arch linux arm running on raspberry-pi and bind 9.9.4.P2-1 from the community repository. I'm using this bind as a slave-nameserver for our internal network. I have enabled named using systemctl enable named.
When I reboot the raspberry pi the named doesn't answer for dig stackexchange.com @xx.xx.xx.xx and runs into a timeout. systemctl status named says named is active and all zones have been successfully loaded.
If I simply login and issue systemctl restart named it provides the correct answer for dig stackexchange.com @xx.xx.xx.xx.

share|improve this question
    
To provide some error messages, you could run named in foreground with enabled debugging switches named -d 9 -f -u user –  user55518 Feb 17 at 12:32

1 Answer 1

I solved the problem by editing : /etc/systemd/system/multi-user.target.wants/named.service

Change : ExecStart=/usr/bin/named -f -u named

To: ExecStart=/usr/bin/named -f -u root

Of course it's not a very good solution ... but it works for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.