Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just got an HP 15-d030nr and installed Mint 16 alongside Win 8.1. My problem is that, without using nomodeset, immediately after choosing an option in GRUB, random pixels flash along the top quarter or third of the screen, which then goes blank, and the backlight shuts off. I can enter my password and hear the login sound, so it's still booting, just with no display. I've tried a lot of the solutions to this problem listed for older Intel hardware to no avail.

Running lspci | grep -i vga gives me 00:02.0 VGA compatible controller: Intel Corporation ValleyView Gen7 (rev 0a)

From what I can tell, Valley View ought to be supported by the kernel (3.11), so I'm pretty lost here.

One of my dmesg logs is here.

Also, I ran into the same issue trying out Fedora, so it's not Just Ubuntu/Mint.

share|improve this question
    
In your logs you have a message about failed module signature along the lines of this Don't know if it's completely or even directly related but maybe it's worth testing something which has >3.11.0-15.23? –  illuminÉ Feb 17 at 2:46
    
I just tried an upgrade to 3.11.10, but no dice. –  9nonnatus Feb 17 at 7:15

2 Answers 2

up vote 0 down vote accepted

juredy at the Linux Mint forums figured it out. Here's his solution verbatim:

  1. Start here: http://kernel.ubuntu.com/~kernel-ppa/mainline/
  2. I used "drm-intel-next/2013-11-05-saucy". (Initially I tried the latest "trusty" kernel, but my laptop turned out to be allergic to it. 30 seconds after boot the fan would go haywire for a few seconds and the system would power off.)
  3. Download and install, in order, "linux-headers...all.deb", "linux-headers...amd64.deb", and "linux-image...amd64.deb".
  4. Reboot! Choose 3.12.0-997 from Grub menu. Voila.

[My note: Even after removing nomodeset or i915.modeset=0 from the kernel parameters I continued to boot into Software Rendering Mode until I deleted my old xorg.conf from /etc/X11]

I also had to fiddle around to get the backlight working properly. It was constantly set at 100% and ignoring my efforts to change it. After a few minutes of research, whaddayaknow... https://wiki.ubuntu.com/Kernel/Debugging/Backlight

If passing parameter to the kernel about acpi_backlight does not work for you with an Intel HD Graphic Controller, or gives you freezes and/or crashes, there is a better way to get it to work.

You simply need to tell the graphic controller which backlight interface to use, i.e. the intel_backlight interface instead of the acpi one.

Create a new file called /usr/share/X11/xorg.conf.d/80-backlight.conf and paste into it the following code

Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "sna" Option "Backlight" "intel_backlight" # use your backlight that works here BusID "PCI:0:2:0" EndSection

If you don't want to use the SNA Acceleration method, remove the appropriate line.

Works like a charm! I also tried with and without "acpi_osi=Linux" and "acpi_backlight=vendor" but there was no effect either way.

share|improve this answer

you could try this:

Search on Debian Forum...

This is my xorg.conf

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "dri"
    Load  "record"
    Load  "dri2"
    Load  "glx"
    Load  "dbe"
    Load  "extmod"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
    Identifier  "Card0"
    Driver      "vesa"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.