Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I had Widonws with two drives C: and D:. In the drive C:, I have my Windows. In the drive D:, I had my all other files and data. I installed Ubuntu in the drive D:, without deleting any data from it. So when I boot my laptop,in boot menu I see both "Windows 7" and "Ubuntu".

When I boot up with Ubuntu, it works well, but I don't have access my data in drive D: (where I installed Ubuntu) anymore. but when I boot up with Windows, I have access to it.

Can anybody help me, how can I have access my data in drive D: from Ubuntu?

this is some information.

sky@ubuntu:~$ sudo fdisk -l
[sudo] password for sky: 

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2f56f4c5

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *    21585920    21790719      102400    7  HPFS/NTFS/exFAT
/dev/sda2        21790720   144670719    61440000    7  HPFS/NTFS/exFAT
/dev/sda3       144670782   625141759   240235489    f  W95 Ext'd (LBA)
/dev/sda5       144670784   562580234   208954725+   7  HPFS/NTFS/exFAT
/dev/sda6       562581504   617027583    27223040   83  Linux
/dev/sda7       617029632   625141759     4056064   82  Linux swap / Solaris


sky@ubuntu:~$ df
Filesystem     1K-blocks      Used Available Use% Mounted on
/dev/loop0      10698000   3015236   7116288  30% /
udev             1947220         4   1947216   1% /dev
tmpfs             782716       880    781836   1% /run
none                5120         0      5120   0% /run/lock
none             1956788       156   1956632   1% /run/shm
/dev/sda5      208954724 114865916  94088808  55% /host
sky@ubuntu:~$

sky@ubuntu:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/host/ubuntu/disks/root.disk /               ext4    loop,errors=remount-ro 0       1
/host/ubuntu/disks/swap.disk none            swap    loop,sw         0       0
sky@ubuntu:~$ 
share|improve this question
    
please can you add the text from command df and cat /etc/fstab ? don't hesitate to edit your question to add any information. because the problem you're describing is really strange as you cannont install ubuntu on a ntfs drive –  Kiwy Feb 14 at 13:38
1  
Did you install Ubuntu autonomously, or as a file in the Windows partition (Wubi)? Please open a terminal and copy-paste the output of the following commands: sudo fdisk -l and df. –  Gilles Feb 14 at 13:46
    
I'm sure op installed Ubuntu via Wubi. –  Avinash Raj Feb 14 at 14:03
    
wubi is not possible for a while now no ? –  Kiwy Feb 14 at 14:04
1  
It sounds like you are mounting your drive over the Windows data. Please add the output of cat /etc/fstab. –  terdon Feb 14 at 14:28

1 Answer 1

It seems that :

From the Wubi Guide

How do I access the Windows drives?

The Windows partition where you installed Wubi is available as /host within Ubuntu (Places > Computer > File System > Host) All the other partitions will be available under Places > > Removable Media

From askUbuntu: Wubi: How do I find partition windows on ubuntu ?

And as fstab show a mount point /host, you can try form a terminal :

cd /host
ls -l

or from Nautilus type Ctrl + L and then type the path /host to access your files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.