Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I disabled this shortcut it via System->Preferences->Keyboard Shortcuts, but it still persists. Furthermore, it takes precedence over Alt-F8 in other apps.

How do I really disable this shortcut? Do I need a reboot after disabling it in Preferences?

share|improve this question
2  
What desktop environment are you using? (The answer should be something like “KDE 5.3.1”, preferably with some additional indications like “under the default configuration of FooBSD, with BarDesktopManager also installed”.) –  Gilles Apr 17 '11 at 12:13
    
@Gilles - Gnome 2.30.2 under Ubuntu 10.04 –  ripper234 Apr 17 '11 at 12:29
    
Did the answer help? –  penguin359 Apr 20 '11 at 20:17
    
@penguin359 - wasn't able to run ccsm yet. –  ripper234 Apr 21 '11 at 10:29
add comment

3 Answers 3

AltF8 is handled by your window manager. In GNOME 2 (with effects enabled) the WM is Compiz. You can use the ccsm tool to edit its keyboard shortcuts.

share|improve this answer
    
How do I run ccsm? 'ccsm' itself isn't installed on my machine. –  ripper234 Apr 21 '11 at 9:58
1  
@ripper234: If it's Ubuntu, install the compizconfig-settings-manager package. –  grawity Apr 21 '11 at 12:25
    
Thanks - but when I opened ccsm, I saw that alt-f8 was really disabled there (remember, I did disable it via the built in configuration). After a system restart, this seems to be resolved. –  ripper234 Apr 21 '11 at 13:12
add comment

Run gconf-editor

Navigate to

/apps/metacity/windows_keybindings/begin_resize

and change it's value to either "" or to anything you like.

[ For safer side, you should reboot the machine ]

share|improve this answer
add comment
up vote 0 down vote accepted

It looks like a restart did it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.