Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I think these problems bother me with the native alt-tab app:

  • It feels a bit sluggish - it takes about 0.3 seconds for the alt-tab window to appear.
  • I'd like to configure Alt-Shift-Tab to go one window backwards (not sure who to do this with the native one).
  • I don't like how the only visible window is the window I'm switching too - I'd like a behavior similar to Windows' alt-tab.
share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Alt-Tab is controlled by your Window Manager. Gnome uses either metacity or compiz if effects are turned on. They each behave slightly differently with Alt-Tab. I don't have any delay with either WM, Alt-Tab is quite fast on my system. If your using Compiz, you try turning down effects in ccsm or try switching to Metacity. Alt-Shift-Tab also works with both WMs. I'm not completely thrilled with Metacity's behavior. When going backwards, it initially skips minimized Windows. Luckily, I rarely find a need to minimize, but it's annoying when I do. Based on your third point, it sounds like the Alt-Tab behavior of Compiz which is just like how Windows 7 ruins Alt-Tab if I hold on one Window for too long. That behavior can be configured with ccsm under Window Management -> Static Application Switcher -> Appearence -> Selected Window Highlight. Try turning Opacity to 100% and/or changing Hilight Mode. Your second issue might be a problem with Key Bindings. Key Binding for Compiz are under Window Management -> Static Application Switcher -> Bindings.

share|improve this answer
    
How do I reach ccsm? (Just running ccsm isn't working. Does it mean I'm not using Compiz? How do I find out what I am using?) –  ripper234 Apr 21 '11 at 10:18
    
Opacity solves my 3rd problem completely. 1st problem solved by setting "popup window delay" to 0. 2nd point - alt-shift-tab does work, but only if you do it from the start. If you start alt-tabbing, but after a few alt-tabs hold shift, it doesn't start going in reverse (very useful if you pass the target window by just one window) . This is still unsolved, but I'll accept your answer because it's great and solved my other issues - thanks. –  ripper234 Apr 21 '11 at 13:44
    
Yes, not having a way to go backwards can get annoying, but I can't seem to reproduce your problem with my Compiz setup. I still suspect it's a binding problem. My binding for Alt-Tab and Shift-Alt-Tab is Next Window and Prev Window, respectively. I also have bindings for Cntrl-Alt-Tab and Cntrl-Shift-Alt-Tab which are Next Window (All Windows) and Next Window (All Windows). It sounds like you finally found ccsm. It was in a separate package on my Ubuntu computer called compizconfig-settings-manager. I've also seen the command spelled out on some systems as well. Hope you get it working! –  penguin359 Apr 21 '11 at 15:59
    
@ripper I forgot to mention you in my reply. I did not notice any difference in behavior between the Control and non Control variation. –  penguin359 Apr 21 '11 at 16:00
add comment

The Alt-Tab handler is not an "app" and doesn't have "replacements" as in Windows. It is part of the window manager.

In GNOME 2 with effects enabled, the WM is Compiz. You can use the ccsm tool to adjust behavior of the "Window Switcher" plugin. (There are two such plugins, by the way.)

share|improve this answer
1  
On the contrary, the Alt+Tab handler is an ordinary application under Unix. It can be (and usually is) the same application that does other things such as provide window frames and a task bar. –  Gilles Apr 17 '11 at 15:33
    
@Gilles: Like I said, the window manager. –  grawity Apr 17 '11 at 15:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.