Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

By the error I can't install any packages. And also I can't update to the latest version. I don't know what to do now. Any help much appreciated.

Error: requested datatype primary not available

OS Info

  • Operating System: Fedora 18
  • Architecture: X86_64

From the internet I've tried the following commands to rebuild the repository. But I'm still getting the same error.

Commands run

# yum clean all
# rpm rebuilddb
# yum grouplist or yum list

More Info

The following are my Repo files:

adobe-linux-x86_64.repo
epel.repo
fedora.repo
fedora-updates.repo
fedora-updates-testing.repo
livna.repo
mysql-community.repo
mysql-community-source.repo
pgdg-92-fedora.repo
rpmfusion-free-rawhide.repo
rpmfusion-free.repo
rpmfusion-free-updates.repo
rpmfusion-free-updates-testing.repo
rpmfusion-nonfree-rawhide.repo
rpmfusion-nonfree.repo
rpmfusion-nonfree-updates.repo
rpmfusion-nonfree-updates-testing.repo
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Clean the cache

For starters I would clean up my cache area.

$ sudo yum clean all

Testing each repo

If that doesn't resolve the issue then I would go through and attempt to disable each repository 1 at a time and then re-run the yum list command to see if that resolves your issue.

You can do this via the command line temporarily, but first you need to get the actual names of the repositories, the names of the files are not necessarily the same thing.

Here I'm using Fedora 19, for example:

$ yum repolist | expand
Loaded plugins: auto-update-debuginfo, changelog, langpacks, refresh-packagekit
repo id                                       repo name                   status
fedora/19/x86_64                              Fedora 19 - x86_64          36,253
fedora-debuginfo/19/x86_64                    Fedora 19 - x86_64 - Debug   6,635
google-chrome                                 google-chrome                    3
rpm-sphere                                    RPM Sphere                   7,679
rpmfusion-free/19/x86_64                      RPM Fusion for Fedora 19 -     462
rpmfusion-free-debuginfo/19/x86_64            RPM Fusion for Fedora 19 -     157
rpmfusion-free-updates/19/x86_64              RPM Fusion for Fedora 19 -     414
rpmfusion-free-updates-debuginfo/19/x86_64    RPM Fusion for Fedora 19 -     149
rpmfusion-nonfree/19/x86_64                   RPM Fusion for Fedora 19 -     219
rpmfusion-nonfree-debuginfo/19/x86_64         RPM Fusion for Fedora 19 -      62
rpmfusion-nonfree-updates/19/x86_64           RPM Fusion for Fedora 19 -     497
rpmfusion-nonfree-updates-debuginfo/19/x86_64 RPM Fusion for Fedora 19 -     170
*updates/19/x86_64                            Fedora 19 - x86_64 - Update 17,597
*updates-debuginfo/19/x86_64                  Fedora 19 - x86_64 - Update  2,241
virtualbox/19/x86_64                          Fedora 19 - x86_64 - Virtua     10
repolist: 72,548

Enabling one repo at a time

So I can see the names of my repos in the very first column. Next you'll want to do `yum list where you disable everything and then enable just one repo, to confirm that it's working right.

$ yum --disablerepo=* --enablerepo=google-chrome list available
Loaded plugins: auto-update-debuginfo, changelog, langpacks, refresh-packagekit
Available Packages
google-chrome-beta.x86_64                                                                               33.0.1750.91-1            

When you get to the repo that's causing an issue you should get that same error you mentioned in your post.

share|improve this answer
    
Thanks for the Troubleshoot tips. I followed the instructions. And end up with following interesting facts. FACT 1 --- I am getting the same error with this command yum repolist | expand FACT 2 --- Then I checked each repo by enabling it individually. epel repo is producing the error which we are talking about. And One more interesting factor is getting another error like "Error getting repository data for ------, repository not found". Those repo's are fedora-updates, fedora-updates-testing, mysql-community-source, mysql-community, pgdg-92-fedora. –  ArunRaj Feb 13 at 7:57
    
@user2959196 - You can also go into the .repo files and change the enabled=1 to enabled=0 as well. –  slm Feb 13 at 8:04
1  
Solved the issue. Thanks @slm –  ArunRaj Feb 13 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.