Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install Elementary OS Luna (based on Ubuntu 12.04 LTS) on my iMac from 2008.

At first I tried the straightforward combination of hdutil and dd to a USB drive, which failed to even show up using rEFInd or holding option.

There is a bug report that requests a Mac ISO, but the conclusion is

This is no longer necessary to install elementary/Ubuntu on a Mac

My second attempt was with https://github.com/SevenBits/Mac-Linux-USB-Loader

This makes the USB bootable. But only when holding option. rEFInd doesn't see it.

So I boot the Live USB and open the Ubuntu installer and proceed to partition a swap and ext4 partition. The installer almost finishes, but crashes on installing grub.

I tried several times on sda, sda1(EFI) and sda6(ext4), all fail.

Then I tried manually installing with

sudo grub-install --root-directory /media/the-mount-point /dev/sda6

This completed after I marked sda6 as a bios partition in gparted.

Now when I boot it shows up in both rEFInd and when holding option, but when selected displays just a cursor.

_

I'm out of ideas. I don't care if I do legacy or EFI booting, as long as I do any booting at all...

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.