Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I need to install an older version of JBoss. 6.1.0 EAP is what has been approved and supported for my application. So when I try to force install the correct version of the jbossas packages the install fails. A number of times in the dependancy resolution stage I get the following error:

Package shrinkwrap is obsoleted by shrinkwrap-impl-base, but obsoleting package does not provide for requirements

Then at the end I get the following error:

Error: Package: jbossas-modules-eap-7.2.0-8.Final_redhat_8.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms)
       Requires: shrinkwrap >= 1.0.0
       Available: shrinkwrap-1.0.0-14.redhat_1.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms)
           shrinkwrap = 1.0.0-14.redhat_1.ep6.el6
       Available: shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch (jb-eap-6-for-rhel-6-server-rpms)
           shrinkwrap = 1.0.0-16.redhat_2.ep6.el6

If I try:

yum install shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch

It changes it to shrinkwrap-impl-base-1.1.2. So I'm not sure the best way to proceed.

Is it possible to force yum to install the 1.0.0 package? If not, is it possible to install shrinkwrap-impl-base then install JBoss and ignore only that dependency? (there are several hundred other dependancies so I don't want to ignore all dependancies.)

Or is there some other solution?

System if RHEL 6.4 with base entitlement and jb-eap-6-for-rhel-6-server-rpms channel installed.

share|improve this question

1 Answer 1

You'd have to confirm first if that older version is even available. I'm on Fedora 19, but you'd run a command similar to this:

$ yum list all shrinkwrap* | expand
Loaded plugins: auto-update-debuginfo, changelog, langpacks, refresh-packagekit
Available Packages
shrinkwrap.noarch                            1.0.0-5.fc19                 fedora
shrinkwrap-descriptors.noarch                2.0.0-0.4.alpha2.fc19        fedora
shrinkwrap-descriptors-javadoc.noarch        2.0.0-0.4.alpha2.fc19        fedora
shrinkwrap-javadoc.noarch                    1.0.0-5.fc19                 fedora
shrinkwrap-resolver.noarch                   1.0.0-0.5.beta7.fc19         fedora
shrinkwrap-resolver-javadoc.noarch           1.0.0-0.5.beta7.fc19         fedora

Downgrading

You can use the yum command downgrade to go down to a specific version.

$ sudo yum downgrade shrinkwrap-1.0.0-16.redhat_2.ep6.el6.noarch

From the man page:

   downgrade
          Will try and downgrade a package from the version currently 
          installed to the previously highest version  (or  the  specified 
          version).  The depsolver will not necessarily work, but if you 
          specify all the packages it should work (thus, all the simple 
          cases will work). Also  this  does  not  work  for "installonly"  
          packages,  like Kernels. downgrade operates on groups, files, 
          provides, filelists and rpm files just like the "install" command.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.