Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
root@ip-10-194-97-94:~# apt-get install uwsgi

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  uwsgi: Depends: uwsgi-python2.6 (>= 0.9.6.5-0ubuntu1~lucid1) or
                  uwsgi-python3.1 (>= 0.9.6.5-0ubuntu1~lucid1)
E: Broken packages
share|improve this question
2  
Ubuntu doesn't ship uwsgi. What source did you add to get the package? If you followed instructions on a web page, link to it. Post the relevant lines in /etc/apt/sources.list or in a file under /etc/apt/sources.list.d. –  Gilles Apr 16 '11 at 18:20
add comment

1 Answer

I think you are using the uwsgi launchpad repo.

It is not obvious, but you shouldn't be touching the uwsgi package, but use the uwsgi-python package instead.

Explanation is given here, they are transferring from uwsgi to the name uwgsi-python.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.