Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
miagos:~ $ uname -a
Linux miagos 3.9.6-200.fc18.x86_64 #1 SMP Thu Jun 13 18:56:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I have a reproducible issue, when my desktop Linux node stays online for more than ~24 hours and any attempt to ssh or scp login, the node just freezes.. no response at all, keyboard, mouse, IP stack halted, no ping response etc.. all frozen and requires a hard reboot.

This only happens anytime after ~24 hours uptime; after a reboot there is no login issue.

After reboot, around ~24 hours later, ssh will ask for my password and only after inputting correct password (attempting to spawn a shell) the machine locks up, a failed password re-asks as normal and an SSH session that does not open a terminal (strictly for Dynamic forwarding) works without lockup within the bug period.

Now I really want to know how to place the node in some type of DEBUG (Kernel or Openssh?) setting to get a clue as the logs (via journalctl) doesn't display anything useful before lockup.

share|improve this question
You start the machine, and when you try to ssh to it, it freezes? Sure that it is running before the ssh attempt? Open a terminal (a VT would probably be best), run a tail -f /var/log/messages in it, try to ssh in and see what the last lines are. That might give a clue. – vonbrand Feb 11 '14 at 1:16
Fedora 18 is end-of-life (or shortly before). consider upgrading. – vonbrand Feb 11 '14 at 1:17
Doesn't freeze initially, only after ~24hours uptime, Ok I will place the sshd server in DEBUG mode and try logging in during the bug period. – joshbaptiste Feb 11 '14 at 3:06

I think I found the problem, out of all my Linux nodes..this Fedora machine is the only one with this setting in /etc/ssh/sshd_config

UsePrivilegeSeparation sandbox

I have changed this to and cycled the sshd daemon

UsePrivilegeSeparation yes

And no lockups at all this past week after ssh login..

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.