Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Running screen I see this:

How can I start screen directly, without this welcome screen?

share|improve this question
    
You can also switch to tmux which does not have startup screen. –  Vi. Feb 10 at 13:26

3 Answers 3

up vote 10 down vote accepted

Add startup_message off to your .screenrc:

startup_message on|off

Select whether you want to see the copyright notice during startup. Default is `on', as you probably noticed.

Actually, the default is to display the startup message only when screen is not passed any argument.

share|improve this answer

You also don't get it if you start screen with the name of a screen session.

$ screen -S newsession

You can then reconnect to it later on:

$ screen -r newsession
share|improve this answer

Browsing through the man-page of screen, I encountered

-f, -fn, and -fa

       turns flow-control on, off, or "automatic switching mode".  This can also be defined through the "defflow" .screenrc command.

And indeed, with screen -f I do not get this kind of splash-screen. Please check with this Flow Control Summary if it somehow interferes with your work, as I do not have experience with this settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.