Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running Ubuntu 13.10 on a Thnkpad X1 Carbon. My Wifi card is Centrino Advanced-N 6205 [Taylor Peak] I normally connect to open WiFi networks using the commands

sudo iw dev wlan0 connect <ESSID> <Frequency> <BSSID>
dhclient wlan0

This method works for me everywhere except in one room on my campus, where the signal is very strong (iwlist reports a signal strength of under -30dB. I am fairly certain there is nothing wrong with the Access Point, because my phone connects to it just fine.

However, when I do the first command above, I am never able to associate with the Access Point, and dmesg always shows a message containing something about ipv6 and Wifi not ready.

I have tried various version of the iwlwifi driver but none of them are able to work for this Access Point.

I am wondering if anyone has suggestions for debugging, such as "turning down the radio power", "turning up the radio power", other obscure settings that can be set on WiFi cards that might help?

I am also interested in knowing what sorts of root causes this kind of problem might have, since my wireless card seems to be able to other networks and AP's just fine.

share|improve this question
    
What about using wpa_supplicant in debug mode? It throws quite a few debug messages. –  yegorich Feb 9 at 7:18
    
I am trying to connect to open networks. Does wpa_supplicant work for non-WPA networks? –  merlin2011 Feb 9 at 7:20
    
Yes. See section "Managed Wireless Network (Wpa_supplicant)" of this manual. –  yegorich Feb 9 at 7:24

1 Answer 1

up vote 1 down vote accepted

You can use wpa_supplicant to connect to open AP. Add following section to the /etc/wpa_supplicant.conf:

ap_scan=1

# no encryption
network={
ssid="TEST"
key_mgmt=NONE
}

You'll find more details in the sample /etc/wpa_supplicant.conf

share|improve this answer
    
Will try this the next time I return to campus, probably Monday. Thanks for pointing this out. –  merlin2011 Feb 9 at 7:53
1  
Amazingly, using wpa_supplicant to connect instead of the raw iw tool actually works. I have no idea why, but this answer addresses the root issue for me. –  merlin2011 Feb 9 at 22:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.