Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

For people from the US with certain cable TV subscriptions, NBC offers footage of the 2014 winter Olympics from a website, nbcolympics.com. However, I find I am unable to view any of the video content from my Linux machine. I have tried from Chrome and Firefox.

Chrome:

When clicking on a video, I am taken to the webpage of the video and all of the non-video content (e.g. the twitter stream, the summary of the video) loads. However, the page is covered in a dark transparent overlay and a "waiting" spinner continuously spins. I cannot click on anything from the web page.

Firefox:

When clicking on a video, I am taken to the webpage of the video and all of the non-video content loads. The page is also covered with a dark, transparent overlay, but this time with a window in the middle to choose my cable provider. When I select my cable provider, xfinity, the page re-loads and the same screen appears again, with the same transparent overlay and the same dialog asking for my cable provider.

Here is a screenshot of the Firefox window: Firefox showing dialog to select cable company

I am using Fedora 19 and do not generally have problems viewing other flash content.

Is there any method to watching the videos on nbcolympics.com from a Linux computer?

share|improve this question
    
Are you sure the site is using flash? Do you have a flash plugin installed? Which Linux are you using? IS it 32 or 64 bit? Could you post a screenshot so we can understand what you're describing better? –  terdon Feb 8 at 16:06
    
Most sites showing video use propietary formats, for which the codecs are patented. Thus you won't find open codecs, and most Linux distributions can't ship them for legal reasons. You might get them from unofficial sites for your distribution. –  vonbrand Feb 8 at 16:12
    
@terdon One reason I think it's flash is n the html source you can see this (for those that don't have flash): <div class="get-flash">You currently do not have the latest version of Adobe Flash Player installed.<br />You will need Flash Player 11.1.102.63 or higher in order to view this site.<br /><br /><a href="http://get.adobe.com/flashplayer" target="_blank">Get the latest version of Flash Player</a></div> –  drs Feb 8 at 16:19

2 Answers 2

up vote 2 down vote accepted

For Fedora, try this.

DISCLAIMER: This is mostly copy-pasted from here.

I'm not really sure if this will work (I don't use Fedora), but it will help you install HAL, and maybe it will. After all, NBC would seem an appropriate place for DRM-laden Flash content to show up.

Anyway, here goes:

First, head to http://get.adobe.com/flashplayer/ and download the "YUM for Linux (YUM)" RPM. Then:

# Install Adobe Flash and its browser plugin
sudo yum install -y adobe-release-x86_64-1.0-1.noarch.rpm
sudo yum install -y flash-plugin

# Install a simple SELinux policy file for Flash
sudo yum install -y policycoreutils-devel
wget http://togami.com/~warren/archive/2012/adobedrm.te
checkmodule -M -m -o adobedrm.mod adobedrm.te
sudo semodule_package -o adobedrm.pp -m adobedrm.mod

wget http://thinkingconcurrently.com/files/f19_flash/fakehal-0.5.14-7.fc19.x86_64.rpm
wget http://thinkingconcurrently.com/files/f19_flash/fakehal-libs-0.5.14-7.fc19.x86_64.rpm



# Install the fakehal RPMs
sudo yum install -y fakehal-0.5.14-7.fc19.x86_64.rpm \
  fakehal-libs-0.5.14-7.fc19.x86_64.rpm

At this point, make sure all Firefox windows are closed.

cd ~/.adobe/Flash_Player

rm -rf NativeCache AssetCache APSPrivateData2

Note: I inserted the above 2 lines based on what unqualified said.

rm -rf ~/.adobe/Flash_Player/
sudo mkdir -p /usr/share/hal/fdi/preprobe \
  /usr/share/hal/fdi/information \
  /usr/share/hal/fdi/policy/20thirdparty \
  /var/cache/hald/
sudo ln -s /usr/share/hal /etc/hal
sudo touch /var/cache/hald/fdi-cache
sudo systemctl start haldaemon.service

The bit I'm unsure about is the line where it deletes the FlashPlayer dir. I would wait for someone to comment and confirm this or reject it before trying it.

I'd repeat, try this at your own risk. I'm not at all sure that this will work or even help.

Anyway, hope you can watch! evamvid

share|improve this answer
1  
Deleting the Flash_player dir is safe. The location in the home directory only stores some user and history settings. The actual flash binaries are stored somewhere else –  drs Feb 9 at 19:58
    
Thanks for the confirm! –  evamvid Feb 9 at 21:41

I had the same problem. Got it to work in Firefox in two steps:

  1. Protected flash content needs HAL to work (per below), but it has been discontinued. So you have to use 'zombie hal' found here: https://launchpad.net/~mjblenner/+archive/ppa-hal by typing

    add-apt-repository ppa:mjblenner/ppa-hal

  2. Otherwise, Adobe has instructions here on the issue, reproduced below:

    sudo apt-get install hal

After the "libhal" (HAL) library install completes, close the browser and clear the Adobe Access directories by executing the following shell commands:

cd ~/.adobe/Flash_Player

rm -rf NativeCache AssetCache APSPrivateData2

Be sure to close the browser before clearing the adobe directories

share|improve this answer
    
Thanks for the solution, but this is specific to Ubuntu. Do you know of a solution for Fedora? –  drs Feb 8 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.