Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When installing Ajenti I get this error:

Error: No information about packages! (Maybe no deb entries?)
E: Problem executing scripts APT::Update::Post-Invoke-Success 'test -x /usr/bin/apt-show-versions || exit 0 ; apt-show-versions -i'
E: Sub-process returned an error code

I have cleared all files in /var/lib/apt/lists. I have cleared all entries and added one-by-one from /etc/apt/sources.list. I have rebooted, twice. apt-get update gives the same error.

I have tried 'dpkg --configure -a' It returns this message:

Setting up apt-show-versions (0.22.3) ...
** initializing cache. This may take a while **
Error: No information about packages! (Maybe no deb entries?)
dpkg: error processing package apt-show-versions (--configure):
 subprocess installed post-installation script returned error exit status 255
dpkg: dependency problems prevent configuration of ajenti:
 ajenti depends on apt-show-versions; however:
  Package apt-show-versions is not configured yet.

dpkg: error processing package ajenti (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 apt-show-versions
 ajenti

Then I have read the first 30 hits in Google, followed all steps in all threads that came out. Deleted all .gz files, created 'partial' directory etc.

Linux debian-imx6 3.0.35-g0f2006c-dirty #161 SMP PREEMPT Tue Dec 31 14:06:45 IST 2013 armv7l GNU/Linux

All commands executed as root.

I read some stuff about bugs, some stuff about bad files in apt dir and some other stuff, I'm looking for some directions on how to fix apt-show-versions.


root@debian-imx6:~# ls -la /usr/bin/apt-show-versions /var/lib/dpkg
-rwxr-xr-x 1 root root 34551 sep 30 12:15 /usr/bin/apt-show-versions

/var/lib/dpkg:
total 4424
drwxr-xr-x  7 root root    4096 feb  8 01:18 .
drwxr-xr-x 47 root root    4096 feb  8 01:03 ..
drwxr-xr-x  2 root root    4096 feb  8 01:11 alternatives
-rw-r--r--  1 root root 1038192 feb  8 01:05 available
-rw-r--r--  1 root root 1010493 feb  8 00:04 available-old
-rw-r--r--  1 root root       8 nov 15 23:21 cmethopt
-rw-r--r--  1 root root     560 dec 16 21:23 diversions
-rw-r--r--  1 root root     448 dec 16 21:23 diversions-old
drwxr-xr-x  2 root root  249856 feb  8 01:17 info
-rw-r-----  1 root root       0 feb  8 01:17 lock
drwxr-xr-x  2 root root    4096 okt  1 21:25 parts
-rw-r--r--  1 root root     116 feb  8 01:11 statoverride
-rw-r--r--  1 root root      70 nov 15 23:30 statoverride-old
-rw-r--r--  1 root root 1086813 feb  8 01:18 status
-rw-r--r--  1 root root 1086813 feb  8 01:17 status-old
drwxr-xr-x  2 root root    4096 feb  8 01:09 triggers
drwxr-xr-x  2 root root    4096 feb  8 01:18 updates

root@debian-imx6:~# apt-show-versions -iv
Unknown option: iv

root@debian-imx6:~# apt-show-versions -i -v
Error: No information about packages! (Maybe no deb entries?)
share|improve this question

closed as off-topic by Faheem Mitha, Anthon, slm, Karlson, Ramesh May 20 at 14:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Faheem Mitha, Anthon, slm, Karlson, Ramesh
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please post the output of ls -la /usr/bin/apt-show-versions /var/lib/dpkg and of apt-show-versions -iv (as root). –  Gilles Feb 8 at 21:21
    
Thank you for your reply, is the second command correct? –  Thijs Feb 8 at 21:47
    
Oh, apt-show-versions doesn't like clustering. apt-show-versions -i -v please. –  Gilles Feb 8 at 21:49
    
Try the below answer. –  Avinash Raj Feb 21 at 15:46
    
Thank you Avinash. Can't try the solution because the entire system is now crashed and I formatted the drive. I'm not sure if I have to delete this question or mark it as answered, there is no 'n/a anymore' button... –  Thijs Feb 22 at 13:30

1 Answer 1

Try to remove the two unconfigured packages by running,

sudo dpkg -P apt-show-versions
sudo dpkg -P ajenti

Then reinstall it again by running,

sudo apt-get install apt-show-versions
sudo apt-get install ajenti
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.