Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an Arris cable modem, and my laptop has a JMC250 PCI Express Gigabit Ethernet Controller. I'm unable to connect to its wired network either with NetworkManager, Wicd, or the command-line on Debian Stable. I have tried also running a Porteus (Slackware based) LiveCD, but the result was the same.

I have tried also many times unloading the jme module and reloading it, with no options, and also with the options force_pseudohp=1, no_pseudohp=1, and no_extplug=1, but to no avail.

I have also tried turning off the rfkill switch, because I can connect to the Wifi without any problems using NetworkManager.

Here is the log from when trying to connect with the NetworkManager:

Feb  5 15:38:50 localhost NetworkManager[2225]: <info> enable requested (sleeping: no  enabled: no)
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> waking up and re-enabling...
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (wlan0): now managed
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (wlan0): bringing up device.
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (wlan0): deactivating device (reason 'managed') [2]
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (eth0): now managed
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (eth0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (eth0): preparing device.
Feb  5 15:38:50 localhost NetworkManager[2225]: <info> (eth0): deactivating device (reason 'managed') [2]

The log from Wicd (which uses standard command-line tools):

2014/02/05 15:35:50 :: Executing /etc/network/if-down.d/upstart with params 
2014/02/05 15:35:50 :: /etc/network/if-down.d/upstart returned 0
2014/02/05 15:35:50 :: Executing /etc/network/if-down.d/wpasupplicant with params 
2014/02/05 15:35:50 :: /etc/network/if-down.d/wpasupplicant returned 0
2014/02/05 15:35:50 :: attempting to set hostname with dhclient
2014/02/05 15:35:50 :: using dhcpcd or another supported client may work better
2014/02/05 15:35:50 :: /sbin/dhclient -v -r wlan0
2014/02/05 15:35:50 :: ifconfig wlan0 0.0.0.0 
2014/02/05 15:35:50 :: /sbin/ip route flush dev wlan0
2014/02/05 15:35:50 :: ifconfig wlan0 down
2014/02/05 15:35:50 :: ifconfig wlan0 up
2014/02/05 15:35:50 :: Executing /etc/network/if-post-down.d/wireless-tools with params 
2014/02/05 15:35:50 :: /etc/network/if-post-down.d/wireless-tools returned 0
2014/02/05 15:35:50 :: Executing /etc/network/if-post-down.d/wpasupplicant with params 
2014/02/05 15:35:50 :: /etc/network/if-post-down.d/wpasupplicant returned 0
2014/02/05 15:35:50 :: wpa_cli -i wlan0 terminate
2014/02/05 15:35:50 :: Executing /etc/network/if-down.d/upstart with params 
2014/02/05 15:35:50 :: /etc/network/if-down.d/upstart returned 0
2014/02/05 15:35:50 :: Executing /etc/network/if-down.d/wpasupplicant with params 
2014/02/05 15:35:50 :: /etc/network/if-down.d/wpasupplicant returned 0
2014/02/05 15:35:50 :: attempting to set hostname with dhclient
2014/02/05 15:35:50 :: using dhcpcd or another supported client may work better
2014/02/05 15:35:50 :: /sbin/dhclient -v -r eth0
2014/02/05 15:35:50 :: ifconfig eth0 0.0.0.0 
2014/02/05 15:35:50 :: /sbin/ip route flush dev eth0
2014/02/05 15:35:50 :: ifconfig eth0 down
2014/02/05 15:35:50 :: ifconfig eth0 up
2014/02/05 15:35:50 :: Executing /etc/network/if-post-down.d/wireless-tools with params 
2014/02/05 15:35:50 :: /etc/network/if-post-down.d/wireless-tools returned 0
2014/02/05 15:35:50 :: Executing /etc/network/if-post-down.d/wpasupplicant with params 
2014/02/05 15:35:50 :: /etc/network/if-post-down.d/wpasupplicant returned 0
2014/02/05 15:35:50 :: wpa_cli -i eth0 terminate
2014/02/05 15:35:50 :: found lastused in configuration True
2014/02/05 15:35:50 :: Executing /etc/network/if-pre-up.d/ethtool with params 
2014/02/05 15:35:50 :: /etc/network/if-pre-up.d/ethtool returned 0
2014/02/05 15:35:50 :: Executing /etc/network/if-pre-up.d/wireless-tools with params 
2014/02/05 15:35:50 :: /etc/network/if-pre-up.d/wireless-tools returned 0
2014/02/05 15:35:50 :: Executing /etc/network/if-pre-up.d/wpasupplicant with params 
2014/02/05 15:35:50 :: /etc/network/if-pre-up.d/wpasupplicant returned 0
2014/02/05 15:35:50 :: Putting interface down
2014/02/05 15:35:50 :: ifconfig eth0 down
2014/02/05 15:35:50 :: Releasing DHCP leases...
2014/02/05 15:35:50 :: attempting to set hostname with dhclient
2014/02/05 15:35:50 :: using dhcpcd or another supported client may work better
2014/02/05 15:35:50 :: /sbin/dhclient -v -r eth0
2014/02/05 15:35:50 :: Setting false IP...
2014/02/05 15:35:50 :: ifconfig eth0 0.0.0.0 
2014/02/05 15:35:50 :: Stopping wpa_supplicant
2014/02/05 15:35:50 :: wpa_cli -i eth0 terminate
2014/02/05 15:35:50 :: Flushing the routing table...
2014/02/05 15:35:50 :: /sbin/ip route flush dev eth0
2014/02/05 15:35:50 :: Putting interface up...
2014/02/05 15:35:50 :: ifconfig eth0 up
2014/02/05 15:35:52 :: Running DHCP with hostname localhost
2014/02/05 15:35:52 :: attempting to set hostname with dhclient
2014/02/05 15:35:52 :: using dhcpcd or another supported client may work better
2014/02/05 15:35:52 :: /sbin/dhclient -v eth0
2014/02/05 15:35:52 :: Internet Systems Consortium DHCP Client 4.2.2
2014/02/05 15:35:52 :: Copyright 2004-2011 Internet Systems Consortium.
2014/02/05 15:35:52 :: All rights reserved.
2014/02/05 15:35:52 :: For info, please visit https://www.isc.org/software/dhcp/
2014/02/05 15:35:52 :: 
2014/02/05 15:35:52 :: Listening on LPF/eth0/80:ee:73:1f:6d:47
2014/02/05 15:35:52 :: Sending on   LPF/eth0/80:ee:73:1f:6d:47
2014/02/05 15:35:52 :: Sending on   Socket/fallback
2014/02/05 15:35:52 :: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
2014/02/05 15:36:00 :: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
2014/02/05 15:36:14 :: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
2014/02/05 15:36:29 :: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 17
2014/02/05 15:36:46 :: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
2014/02/05 15:36:53 :: No DHCPOFFERS received.
2014/02/05 15:36:53 :: No working leases in persistent database - sleeping.
2014/02/05 15:36:53 :: DHCP connection failed
2014/02/05 15:36:53 :: exiting connection thread
2014/02/05 15:36:53 :: Sending connection attempt result dhcp_failed
2014/02/05 15:36:53 :: ifconfig eth0
2014/02/05 15:36:53 :: ifconfig wlan0
2014/02/05 15:36:53 :: Forced disconnect on
2014/02/05 15:36:53 :: iwconfig wlan0
2014/02/05 15:36:53 :: Executing /etc/network/if-down.d/upstart with params 
2014/02/05 15:36:53 :: /etc/network/if-down.d/upstart returned 0
2014/02/05 15:36:53 :: Executing /etc/network/if-down.d/wpasupplicant with params 
2014/02/05 15:36:53 :: /etc/network/if-down.d/wpasupplicant returned 0
2014/02/05 15:36:53 :: attempting to set hostname with dhclient
2014/02/05 15:36:53 :: using dhcpcd or another supported client may work better
2014/02/05 15:36:53 :: /sbin/dhclient -v -r wlan0
2014/02/05 15:36:53 :: ifconfig wlan0 0.0.0.0 
2014/02/05 15:36:53 :: /sbin/ip route flush dev wlan0
2014/02/05 15:36:53 :: ifconfig wlan0 down
2014/02/05 15:36:53 :: ifconfig wlan0 up
2014/02/05 15:36:53 :: Executing /etc/network/if-post-down.d/wireless-tools with params 
2014/02/05 15:36:53 :: /etc/network/if-post-down.d/wireless-tools returned 0
2014/02/05 15:36:53 :: Executing /etc/network/if-post-down.d/wpasupplicant with params 
2014/02/05 15:36:53 :: /etc/network/if-post-down.d/wpasupplicant returned 0
2014/02/05 15:36:53 :: wpa_cli -i wlan0 terminate
2014/02/05 15:36:53 :: Executing /etc/network/if-down.d/upstart with params 
2014/02/05 15:36:53 :: /etc/network/if-down.d/upstart returned 0
2014/02/05 15:36:53 :: Executing /etc/network/if-down.d/wpasupplicant with params 
2014/02/05 15:36:53 :: /etc/network/if-down.d/wpasupplicant returned 0
2014/02/05 15:36:53 :: attempting to set hostname with dhclient
2014/02/05 15:36:53 :: using dhcpcd or another supported client may work better
2014/02/05 15:36:53 :: /sbin/dhclient -v -r eth0
2014/02/05 15:36:53 :: ifconfig eth0 0.0.0.0 
2014/02/05 15:36:53 :: /sbin/ip route flush dev eth0
2014/02/05 15:36:53 :: ifconfig eth0 down
2014/02/05 15:36:53 :: ifconfig eth0 up
2014/02/05 15:36:53 :: Executing /etc/network/if-post-down.d/wireless-tools with params 
2014/02/05 15:36:53 :: /etc/network/if-post-down.d/wireless-tools returned 0
2014/02/05 15:36:53 :: Executing /etc/network/if-post-down.d/wpasupplicant with params 
2014/02/05 15:36:53 :: /etc/network/if-post-down.d/wpasupplicant returned 0
2014/02/05 15:36:53 :: wpa_cli -i eth0 terminate

Some other info:

$ sudo ethtool eth0
Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Speed: 10Mb/s
    Duplex: Half
    Port: MII
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pg
    Wake-on: g
    Current message level: 0x000020c6 (8390)
                   probe link rx_err tx_err hw
    Link detected: no

$ sudo nm-tool 

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            jme
  State:             unavailable
  Default:           no
  HW Address:        80:EE:73:1F:6D:47

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off
share|improve this question

2 Answers 2

The ethtool output says it all:

Link detected: no

Either the network cable, the interface itself, or what you're connecting to, is damaged/broken. The fact that you've even tried multiple OSs, and they all behave the same, supports this.

Basically this isn't a software issue.

share|improve this answer
    
Thanks a lot for your answer! Could it be a modem configuration problem? I reset it yesterday, but the default settings could have some problems, I think... I could configure it through the Wifi. –  Teresa e Junior Feb 6 at 13:45
    
configuration problem? doubt it, but it is technically possible. Just start ruling things out. Replace cable, replace laptop, replace modem. See which fixes it. –  Patrick Feb 6 at 17:32
    
OK, thank you! Although I don't have any more laptops, modems or cables :( I'll see what I can do... –  Teresa e Junior Feb 6 at 17:36
up vote 1 down vote accepted

Thanks God I insisted on this :) Taken from the Ubuntu forums:

sudo ethtool -s eth0 autoneg off speed 100 duplex full

Results after running this command:

Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes:  Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: pg
Wake-on: g
Current message level: 0x000020c6 (8390)
               probe link rx_err tx_err hw
Link detected: yes
share|improve this answer
    
Glad this solved your issue, but it usually means something is failing. Like the signal quality is so poor that it isn't capable of negotiating a speed properly. I'd still advise trying to at least swap out the ethernet cable as it's the most likely culprit. Though you might be able to confirm this without replacing anything by looking at the "errors" counters of ifconfig. –  Patrick Feb 12 at 7:30
    
Thank you, @Patrick! –  Teresa e Junior Feb 12 at 22:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.