Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Error

I keep getting this error message each time I start GNOME, even though I created a new partition table on this drive, I formatted all the partitions, and created them again, and this just won't go away.

Any suggestions?

Edit:

I ran badblocks, and this is what I got

badblocks -svw /dev/sdb Checking for bad blocks in read-write mode From block 0 to 80042206 Testing with pattern 0xaa: done
Reading and comparing: done
Testing with pattern 0x55: done
Reading and comparing: done
Testing with pattern 0xff: done
Reading and comparing: done
Testing with pattern 0x00: done
Reading and comparing: done
Pass completed, 0 bad blocks found

share|improve this question
    
What happens when you click the icon? –  Gilles Apr 15 '11 at 19:17
    
@Gilles It says that the disk has too many bad sectors, I click on it, the message disappears, but the icon just stays there. –  Mahmoud Hossam Apr 15 '11 at 23:33

2 Answers 2

up vote 1 down vote accepted

Open System->Administration->Disk Utility, select your hard drive from the list on the left and then click SMART Data on the right. You will get a report about your disk status and errors.

You may continue by clicking the Run Self-test button and start an Extensive self-test. Wait until it's finished and read the final report. Running badblocks or e2fsck -c (from your live rescue disk) on your filesystems will mark bad clusters so they won't be used by the OS. But if error counters keep rising by time, your disk needs replacement asap. You should already have a backup.

Unfortunately, current inexpensive disks are as reliable as floppy disks were a decade ago. Though, being inexpensive makes raid1 (mirror) a considerable option for desktop systems too.

EDIT

I thought Disk Utility was installed by default in Ubuntu. The package's name is gnome-disk-utility, so one way to install it is sudo apt-get install gnome-disk-utility. Get the same functionality in command line with smartctl from smartmontools package.

EDIT2

I forgot that there was a bug with gnome-disk-utility reporting false warnings. I don't know if it's fixed yet, I never experienced it myself. More info in dealing with disk problems here.

share|improve this answer
    
I don't have Disk Utility, I only have disk usage analyzer, I don't think it's what you're referring to, I'll try one of those two commands you've mentioned, though. –  Mahmoud Hossam Apr 15 '11 at 9:35
    
@Mahmoud Hossam, updated my answer. –  forcefsck Apr 15 '11 at 9:40
    
@forcefsck I use mandriva. –  Mahmoud Hossam Apr 15 '11 at 9:41
    
@Mahmoud Hossam, they all look alike these days :) . Package names are more or less the same in most distros. Use the distro's package manager to install it. –  forcefsck Apr 15 '11 at 9:45
    
@forcefsck hmm...that's interesting, gnome-disk-utility is already installed, yet there's no program with this name, even when I'm root, however, I ran badblocks and it's checking the device right now. –  Mahmoud Hossam Apr 15 '11 at 11:18

Replace your hard drive?

Did you click the icon for more information? It sounds like your drive's S.M.A.R.T. firmware is reporting an imminent hardware failure. Keep those backups up to date.

share|improve this answer
    
That's a secondary hard drive that I don't use very often, I don't have any problems with it if it fails, is there a way to get rid of this notification while keeping it for now? –  Mahmoud Hossam Apr 15 '11 at 9:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.