Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My console yakuake is outputting the wrong single quote character.

test.cpp: In function âint main()â:

I've tried, one by one:

export LC_CTYPE="C"    
export LC_CTYPE="posix"
export LC_ALL="en_CA.UTF-8"
export LC_COLLATE=C
export LC_MESSAGES=C

but that didn't work, it still outputting that character instead of a single quote.

my current locale output:

LANG=en_CA.UTF-8
LC_CTYPE="en_CA.UTF-8"
LC_NUMERIC="en_CA.UTF-8"
LC_TIME="en_CA.UTF-8"
LC_COLLATE="en_CA.UTF-8"
LC_MONETARY="en_CA.UTF-8"
LC_MESSAGES="en_CA.UTF-8"
LC_PAPER="en_CA.UTF-8"
LC_NAME="en_CA.UTF-8"
LC_ADDRESS="en_CA.UTF-8"
LC_TELEPHONE="en_CA.UTF-8"
LC_MEASUREMENT="en_CA.UTF-8"
LC_IDENTIFICATION="en_CA.UTF-8"
LC_ALL=

my font was "Anka Coder Condensed".

How can I fix this?

share|improve this question
1  
Does yakuake have a character encoding option? It looks like it's set to ISO 8859-1, but you need to set it to UTF-8. –  Mikel Feb 5 at 2:58
    
It's also interesting that you mention your font, but don't say you tried any other font. I don't think it's a font issue, but please try another font if you think that's the problem, and report back. –  Mikel Feb 5 at 3:03

1 Answer 1

up vote 2 down vote accepted

Your character encoding is wrong. I was able to reproduce your problem by setting it to Western European > ISO 8859-1, but any other Western European encoding likely causes the same symptoms.

Try right clicking inside your yakuake window, choosing Set Encoding > Unicode > UTF-8.

share|improve this answer
    
thank you mikel, this is the correct answer.. –  Kokizzu Feb 5 at 3:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.