Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been trying to install Debian Lenny on my new machine, alongside Windows 7 64-bit. When I get to the part where it detects my disks, it can't find any. I have a 1GB FAT32 flash drive that it detects if it is in, but it doesn't see my Hitachi drive or my USB Seagate. I partitioned a 100GB partition on the internal Hitachi drive as FAT32. Does anyone have any ideas?

MOBO: Asus X58 Sabertooth HDD: Hitachi HDT721010SLA360 SCSI Disk Drive

share|improve this question
2  
That motherboard is pretty recent and you're installing an old distribution that may not have drivers for it. Have you tried something more recent, such as the current release of Debian (squeeze)? –  Gilles Apr 15 '11 at 19:29
add comment

migrated from stackoverflow.com Apr 15 '11 at 3:17

This question came from our site for professional and enthusiast programmers.

4 Answers

You need the device driver for your SCSI controller compiled into your kernel. Or, use an initrd with the driver in it. What kind of controller is it? Perhaps it's too new to even have a driver.

share|improve this answer
    
It is ICH10R, not exactly new (2008) –  9000 Jun 14 '11 at 21:28
    
I had similar problems with an Intel motherboard with the X58 chipset. It wouldn't boot off the hard disk. Kernel hung. But later kernels fixed it. If you try to put an old kernel on an X58 board it may not work. –  Keith Jun 14 '11 at 22:15
add comment

Do lspci and see if you can see any PATA/SATA/SCSI/SAS controllers. If you do, google around for its name, and you'll find the name of the driver for it. Load it, and see if your drive shows up (fdisk -l or cat /proc/partitions usually does the trick).

For USB storage, you need apopriate USB modules (uhci/ehci/ohci) and then usb-storage. The name of the drivers have changed quite a bit over the years, so be mindful which kernel version you're using, as it will affect the name of what you need to load.

share|improve this answer
add comment

Just a thought... maybe you could try to disable ACPI mode in your BIOS? I may be way, way, way off base here, but you could give it a shot.

share|improve this answer
add comment

As others said, you need to boot a kernel that is actually able to deal with the disk controller in the motherboard. Even if you install an old version of some distro, you need the kernel to have a driver for the controller (depending on the distro, you may have to do a lot work to install a newer kernel, or maybe it's really just a matter of fetching and compiling).

Try seeing if the BIOS setup allows you to enable some "legacy" operation mode for the disk controller, maybe that way you can go far enough to have debian installed so that the only thing left is to update the kernel.

And don't forget this (or any other issue regarding lack of "default" kernel support) requires two different things:

  1. The kernel used to boot the installation environment;
  2. The kernel that gets installed with the system you're installing.

So, let's say you manage to solve (1) by using, e.g., a recent copy of Knoppix to boot the computer (either using a pendrive, toram, two optical drives, or other procedure that lets you run the debian installer from knoppix), then you will be able to install the system, but you won't be able to boot the installed system.

To achieve (2) you can either just copy the kernel you used to boot the installation environment (which may involve some hackery if the kernel uses some initrd (as do many livecds) that is not compatible with the way Debian does stuff), or build one from source.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.