Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Putty to ssh into a RedHat box, and I'm running GNU emacs inside the putty ssh window.

When I turn on whitespace-mode using M-x whitespace mode, I notice I see a "Â" before each space or tab character:

····this·is·some·spaces$
»       this·is·a·tab$

has anyone seen this before? I suspect its because of my terminal settings.

share|improve this question
add comment

1 Answer

up vote 7 down vote accepted

· in latin1 is the byte sequence c2 b7. That same byte sequence interpreted in UTF-8 is the character ·. So what's happening is that Emacs believes your terminal displays UTF-8 (Unicode) but your terminal actually displays latin1.

PuTTY supports UTF-8, so the easiest solution is to tell it to use UTF-8, at least when connecting to this host. As an added benefit, you'll be able to use characters outside latin1.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.