Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to mirror all files for example KDEs to local directory. I used

$ wget -m -P ./kde http://alien.slackbook.org/ktown/current/4.12.1/x86_64/kde/

But after a while it broke. To continue I added -c option and tried again. As :

$ wget -c -m -P ./kde http://alien.slackbook.org/ktown/current/4.12.1/x86_64/kde/

But got the following error (I get error in second time I tried if it downloaded index.html previously):

Saving to: './kde/alien.slackbook.org/ktown/current/4.12.1/x86_64/kde/index.html'

[ <=> ] 0 --.-K/s in 0s

Cannot write to './kde/alien.slackbook.org/ktown/current/4.12.1/x86_64/kde/index.html' (Success). Converted 0 files in 0 seconds.

And downloading breaks again at this point. How should I continue a wget mirroring?

share|improve this question
2  
Are you sure you have enough disk space in there ? df -h . –  Slyx Feb 4 at 5:08
    
@Slyx: Yes: 99G 49G 45G 52% /home –  Mohammad Etemaddar Feb 4 at 5:33

1 Answer 1

It seems to be caused by a bug in wget that makes it fail on long URLs, or on writing to file names it had derived from long ursl.

See wget starts downloading then stops “cannot write to”

This but looks related, for example: bug #21714: File name too long

The problem may be solved already in the current version of wget - let us know the version you use if it still exists.

share|improve this answer
    
Thanks for your detailed answer. I'm using version 1.14; I will update to newer version and then report in short while. Thanks. –  Mohammad Etemaddar Aug 27 at 9:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.