Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been using Linux Mint Debian with Debian unstable and noticed that when I press restart, instead of going all the way back to the BIOS, then grub, then booting up, I seem to be shutting down then loading back up without going back to the BIOS or GRUB.

This is an amazing feature I have not seen before until now. What is this called and when did it happen? I had been a user of Ubuntu for a long time.

share|improve this question
    
Are you sure it's actually rebooting? It sounds like it's just restarting X –  Michael Mrozek Apr 13 '11 at 19:10
    
Yes I watch it all the way, shuts every thing off then begins right where a normal cold boot would –  Seth Hikari Apr 13 '11 at 19:21

1 Answer 1

up vote 11 down vote accepted

It looks like your system has kexec enabled. Kexec allows the Linux kernel to load another kernel and hand the system over to that system. It's named after the exec family of functions that replace a process by a new executable image. Instead of calling the reboot utility, your system is set up to call kexec when you reboot, and the kernel does the rest.

share|improve this answer
    
Found that package in my system must be it. Awesome –  Seth Hikari Apr 14 '11 at 5:25
    
Interesting. This can be enabled in Debian with kexec-tools (the stock Debian kernels have kexec support), and installation of kexec-tools enables kexec by default, though I have not tested it. Looks like Ubuntu (and Mint) have it by default. My system has debconf priority high, & I didn't see a debconf screen when enabling, so I conclude that the question is set to priority medium or low, though I forget how to check how to find out the debconf priority for a template. Would anyone like to remind me? Might be a reasonable question here - Google doesn't immediately provide an answer. –  Faheem Mitha Apr 14 '11 at 8:57
    
For the record, this is set in the config file, in this case /var/lib/dpkg/info/kexec-tools.config. See the line "db_input medium kexec-tools/load_kexec || true". –  Faheem Mitha Apr 14 '11 at 9:11
    
Just an hint: if you are using kexec and you need a "cold" reboot (i.e. passing through BIOS, ...), you can use /sbin/coldreboot (at least in Debian, it is part of kexec-tools package). –  meden Dec 19 '12 at 11:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.