Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using mount.cifs on openSUSE 11.3, I'm getting very slow performance on a gigabit network, usually around 4-5MB/s. The following mount command has yielded me the best performance so far:

mount.cifs //server/share /mnt/share -o user=aduser,domain=ADDOMAIN,uid=aduser,nogrp,nobrl

Windows 7 on the same network gets almost full gig.

What else can I try to make it faster?

share|improve this question
Win7 and SuSE are the same box, dualboot? What OS and software is the server side? – forcefsck Apr 15 '11 at 8:30
Yes, dualboot. Multiple servers: some Windows 2003 & some OS X 10.6.7 Server. – churnd Apr 15 '11 at 10:51
I don't know of anything offhand that would do this. Have you taken a look at the output of mount.cifs with the --verbose option already? My guess would be that it has something to do with the driver under Linux. Can you replicate the problem with the same version of openSUSE on a different computer or with a different brand/model of NIC on the same computer? – tak Apr 16 '11 at 3:36
The network is not the problem. On this computer, I can max out the gigabit link to a NFS share to the Windows & OS X server. Rsync also goes about 50MB/s. Any type of SMB/CIFS trickles along at 4-5MB/s. – churnd Nov 15 '11 at 13:07

CIFS can get to work slow if the network speeds of the host does not negotiate properly with that of the CIFS server in another network. I have had this problem in the past where the CIFS server was in different VLAN and the client host(Windows) in another with different but higher speed. Network speed of the server should be negotiated and (in most cases) should match with that of the client's speed.

share|improve this answer
Network speeds are identical between server & client. – churnd Mar 15 '12 at 10:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.