Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

We moved a web-based application to a new server recently, but the new server seems to run slower than the old one. The old server was FreeBSD 7 with Apache 2.2, mod_php 5.3, and mySQL 5.1. The new server is Debian 7 with Apache 2.2, mod_php 5.4, and mySQL 5.5.

As far as I can tell, the configurations are pretty much stock.

The old server took a long time to display results (10+ seconds, 30 at times), but it displayed results as it got them. The new server seems to take about the same amount of time, but it doesn't display any results until the entire page is ready. This makes the application "feel" slower, because anything you do results in a 10+ second delay before you get any response while it loads the page.

Why would the new server be buffering the page (if that's what it's doing). Is there some configuration setting I can change to make it stop?

share|improve this question
1  
Were going to need to know the exact hardware config of each box. In something like this the smallest thing (like hard drive speed or partition layout for example) can make a huge difference in speed. As for buffering... –  coteyr Feb 3 at 15:51
    
you should rewrite your app to use XHR to get content that is rendered out of band. (or something) a 10 second web request is server killing on any site with traffic. –  coteyr Feb 3 at 15:53
    
I decided to try to duplicate the results. I grabbed another server, installed FreeBSD 9.2 and Debian 7.3 in a dual-boot setup. The FreeBSD system exhibits the old behavior, and the Debian system exhibits the new behavior. This is with stock configurations on both. So it must be a configuration issue or an OS issue. I just don't know where to look. –  John David Ratliff Feb 3 at 19:35
    
I'd suggest using something such as firebug to see what happens in the browser.. Or profile the network between the client and the new server.. Did you see anything suspicious in the apache and mysql log files? –  Alvin Sim Feb 4 at 9:10

1 Answer 1

I found the solution. The problem is mod_deflate, which is enabled by default on debian, but is not used on FreeBSD by default. Turning off mod_deflate gives me output on demand.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.