Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I try to play MP4 files in mplayer, after a few seconds I get the "Your system is too SLOW to play this!" warning and the video starts lagging behind the audio. It only happens with MP4s, and seems to happen with just about all of them. mplayer doesn't seem to be overtaxing my system, it's just something with playing that particular format. I tried all the mplayer suggestions (different video driver, -framedrop, etc.); the only one that even partially helps is -autosync 30, but that's a hack. What could be wrong? How do I go about debugging/fixing it?


Edit: My video card is an nVidia; I use the official drivers. My available video output drivers according to mplayer are:

    xv  X11/Xv
    gl_nosw OpenGL no software rendering
    x11 X11 ( XImage/Shm )
    xover   General X11 driver for overlay capable video output drivers
    gl  OpenGL
    gl2 X11 (OpenGL) - multiple textures version
    matrixview  MatrixView (OpenGL)
    null    Null video output
    mpegpes MPEG-PES file
    yuv4mpeg    yuv4mpeg output for mjpegtools
    png PNG file
    jpeg    JPEG file

I haven't tried any other players (I don't think I even have any), but I'll try installing another one and see if it has the same problem. I forgot to mention that I have this problem on multiple computers, but they all have essentially the same setup so it's probably a common cause

share|improve this question
2  
Buggy codec? Did you try playing MP4s in another player? Potentially useful info: what video driver(s) (-vo) in mplayer, what video driver(s) in X? –  Gilles Apr 13 '11 at 19:54
    
Either use the vdpau or use the mplayer argument "framedrop". May be either one of them help you out. –  SHW May 5 '11 at 10:34
add comment

1 Answer 1

With nvidia there are always such problems. Your mplayer is using probably some type of hw acceleration, which can be sometimes buggy (I've seen good working and buggy nvidia systems as well). A simple x11 output (-vo x11) will probably work.

You can try yet the -framedrop flag. If it don't works, then with a -hardframedrop will also work if you use some lowlevel output driver.

On todays PCs a simple -vo x11 -framedrop is also o.k., and it at least eliminates the problems of the buggy lowlevel things (which are in case of nvidia very probable).

Practically, there are 3 different nvidia drivers:

  • the driver in X.Org
  • the closed-source nvidia driver
  • and there is an opensource clone of the closed-source nvidia as well.

These have different combos. If you aren't happy with -vo x11, you could start to play with them.

share|improve this answer
    
I've used mplayer fairly extensively with nVidia hardware and VDPAU. It seems to mostly work. And can't recall ever seeing a problem with -vo xv (which should be faster than -vo x11 and also supports hardware scaling). Also, OP says -autosync fixed it, but that shouldn't help if there is actually a video bug causing slowdown. -autosync typically works around audio driver bugs. –  derobert May 16 at 18:10
    
@derobert Out of the base X.Org there is an opensource nvidia driver and a closed as well. Maybe your hw-sw combination was okay. I also experienced good working nvidia systems. I extended my answer, maybe it worths a voting change. –  Peter Horvath May 16 at 18:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.