Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to run Rygel, a UPNP media server, on a headless Fedora 20 system. I installed Rygel, and created a dedicated user and systemd unit for it. Rygel starts but it is not listening on the port I asked it to. I think this is because it fails to get a list of network interfaces from NetworkManager. How can I give it permission to talk to NetworkManager over DBUS?

NOTE: Both NetworkManager and dbus-daemon are confirmed running.

Output from starting Rygel:

Feb 02 19:13:08 inspiron systemd[1]: Starting Rygel DLNA server...
Feb 02 19:13:08 inspiron systemd[1]: Started Rygel DLNA server.
Feb 02 19:13:09 inspiron rygel[2276]: Rygel-Message: rygel-main.vala:87: Rygel v0.20.3 starting…
Feb 02 19:13:09 inspiron dbus-daemon[465]: dbus[465]: [system] Rejected send message, 3 matched rules; type="method_call", sender=":1.95" (uid=1001 pid=2276 comm="/usr/bin/rygel -c /etc/rygel.conf ") interface="org.freedesktop.NetworkManager" member="GetDevices" error name="(unset)" requested_reply="0" destination=":1.12" (uid=0 pid=566 comm="/usr/sbin/NetworkManager --no-daemon ")
Feb 02 19:13:09 inspiron dbus[465]: [system] Rejected send message, 3 matched rules; type="method_call", sender=":1.95" (uid=1001 pid=2276 comm="/usr/bin/rygel -c /etc/rygel.conf ") interface="org.freedesktop.NetworkManager" member="GetDevices" error name="(unset)" requested_reply="0" destination=":1.12" (uid=0 pid=566 comm="/usr/sbin/NetworkManager --no-daemon ")
Feb 02 19:13:09 inspiron rygel[2276]: ** (rygel:2276): WARNING **: Error fetching list of devices: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 3 matched rules; type="method_call", sender=":1.95" (uid=1001 pid=2276 comm="/usr/bin/rygel -c /etc/rygel.conf ") interface="org.freedesktop.NetworkManager" member="GetDevices" error name="(unset)" requested_reply="0" destination=":1.12" (uid=0 pid=566 comm="/usr/sbin/NetworkManager --no-daemon ")
Feb 02 19:13:09 inspiron rygel[2276]: Rygel-Message: New plugin 'MediaExport' available

My Rygel systemd configuration:

[Unit]
Description=Rygel DLNA server
After=syslog.target

[Service]
User=rygel
Group=rygel
ExecStart=/usr/bin/rygel -c /etc/rygel.conf

[Install]
WantedBy=multi-user.target

My (slightly redacted) rygel configuration:

[general]
upnp-enabled=true
video-upload-folder=@VIDEOS@
music-upload-folder=@MUSIC@
picture-upload-folder=@PICTURES@
media-engine=librygel-media-engine-gst.so
interface=192.0.2.100
port=49152
log-level=*:5
allow-upload=false
allow-deletion=false

[GstMediaEngine]
transcoders=mp3;lpcm;mp2ts;wmv;aac;avc

[Renderer]
image-timeout = 15

[MediaExport]
enabled=true
title=@REALNAME@'s media
uris=/path/to/media
extract-metadata=true
monitor-changes=true
virtual-folders=true

[Tracker]
enabled=false

[Playbin]
enabled=false

[ZDFMediathek]
enabled=false

[GstLaunch]
enabled=false

[Test]
enabled=false

[ExampleServerPluginVala]
enabled=false

[ExampleServerPluginC]
enabled=false

[ExampleRendererPluginVala]
enabled=false

[ExampleRendererPluginC]
enabled=false

[MPRIS]
enabled=false

[External]
enabled=fals
share|improve this question
add comment

1 Answer 1

I found this blog post which sounds like what you're looking for. It's titled: Setting up rygel on your Fedora system.

NOTE: The following is excerpted from that blog post

  1. Install packages

    $ sudo yum install rygel tumbler gupnp-av
    

    Tumbler is a dbus thumbnailer. If you don’t install it, rygel gives an error saying a dbus thumbnailer isn’t available. It also gives an error saying it couldn’t find “/usr/share/gupnp-av/didl-lite-v2.xsd”, and the gupnp-av package provides this. I’ve got to look into both these and see if they should be required by rygel by default.

  2. Copy config file

    $ cp /etc/rygel.conf ~/.config/rygel.conf
    

    Modify the config file. For example, I enabled the tracker plugin since I’m on gnome3. An important change is to use a fixed port, so you always know which one needs to be opened in your firewall. I randomly picked 65530. You can pick any that isn’t already reserved.

  3. Open the firewall ports (UDP:1900 & TCP:65530)

    $ sudo firewall-cmd --add-port=1900/udp
    $ sudo firewall-cmd --add-port=65530/tcp
    
    check results
    $ sudo firewall-cmd --list-ports
    1900/udp 65530/tcp
    
share|improve this answer
    
None of this addresses the error I experienced. I've already configured rygel and opened the firewall. My problem is that rygel is not listening on either port 1900 or 49152. –  sciurus Feb 3 at 15:21
    
@sciurus - the issue with installing tumbler sounded relevant to your issue. –  slm Feb 3 at 15:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.