Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Arch Linux (Linux 3.13), when I run qtcreator, it crashes, and the same happens for other Qt based software:

$ qtcreator
"Qt Warning - invalid keysym: dead_actute" 
Segmentation fault (core dumped)

$ qtalarm 
"Qt Warning - invalid keysym: dead_actute"  
Segmentation fault (core dumped)

all my "qt" installed packages are:

gambas3-gb-qt4 3.5.2-1
gambas3-gb-qt4-ext 3.5.2-1
gambas3-gb-qt4-opengl 3.5.2-1
gambas3-gb-qt4-webkit 3.5.2-1
kdebindings-qtruby 4.12.1-1
kdebindings-smokeqt 4.12.1-1
libdbusmenu-qt 0.9.2-2
phonon-qt4 4.7.1-1
polkit-qt 0.103.0-2
poppler-qt4 0.24.5-1
pyqt4-common 4.10.3-1
python2-pyqt4 4.10.3-1
qt4 4.8.5-7
qt5-base 5.2.0-3
qt5-declarative 5.2.0-3
qt5-graphicaleffects 5.2.0-3
qt5-imageformats 5.2.0-3
qt5-jsbackend 5.1.1-5
qt5-location 5.2.0-3
qt5-multimedia 5.2.0-3
qt5-qtsystems-git 20130509-1
qt5-quick1 5.2.0-3
qt5-quickcontrols 5.2.0-3
qt5-script 5.2.0-3
qt5-sensors 5.2.0-3
qt5-serialport 5.2.0-3
qt5-svg 5.2.0-3
qt5-tools 5.2.0-3
qt5-translations 5.2.0-3
qt5-webkit 5.2.0-3
qt5-x11extras 5.2.0-3
qt5-xmlpatterns 5.2.0-3
qtalarm 4700237.6-1
qtchooser 39-1
qtcreator 3.0.0-2
qtwebkit 2.3.3-1
telepathy-qt 0.9.3-7

How can I find out what's wrong (what the cause of the problem is) on my system?

share|improve this question
    
To find out what's wrong with the warning and how to fix it see my answer below. –  Alex Butum Feb 22 at 15:04

3 Answers 3

The typo inside libX11 has been fixed upstream with commit 5dcb40f28d59587597d2ff6e6ac64c71cfe6ff7b and date 2013-09-17, and if you look at the commit log you'll see that this commit is above the last commit which got into release 1.6.2 of libX11. (2013-09-13)

The 1.6.2 release is currently used in the extra repository on ArchLinux: https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/libx11#n5

Which means that the fix upstream hasn't got into the Arch repos yet, we'll have to wait for the next release of libX11 which hasn't happened as of current date.

Until the next release of libX11 you can fix this yourself by doing:

sudo sed -i -e 's/dead_actute/dead_acute/' /usr/share/X11/locale/en_US.UTF-8/Compose

After that, the message "Qt Warning - invalid keysym: dead_actute" displayed when starting a Qt based application will be gone.

As for the SIGSEGV problem, try to run Qt Creator, or the other Qt based apps your trying to run through Valgrind or the tools mentioned here and check the output.

share|improve this answer

dead_actute is a typo and should be dead_acute.

Always make sure to take any errors that get produced by tools and search on them. Most of the time if one person is encountering an error there are bound to be more.

share|improve this answer
    
that's just warning, the error was "Segmentation Fault" –  Kokizzu Jan 28 at 3:04
    
Have you tried to fix the dead_actute bug? Maybe it's the cause of the segmentation fault –  daniel kullmann Jan 28 at 8:35
    
@danielkullmann The warning cannot be the cause of the segfault –  Alex Butum Feb 22 at 15:06
up vote 0 down vote accepted

reinstalling qt packages solves the problem..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.