Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using debian sid with xfce.

I would like to test last version of gnome (I didn't give gnome 3.x a chance).

Therfore, I would like to install gnome but, also, to know how to go back to my xfce desktop. My worries are to have hard time to uninstall all packages installed for gnome.

I plan to install gnome with :

apt-get install gnome

Which produces:

The following extra packages will be installed:
  accountsservice aglfn aisleriot alacarte apg argyll bluez bogofilter bogofilter-bdb
  bogofilter-common browser-plugin-gnash caribou caribou-antler cheese cheese-common cli-common
  cracklib-runtime dconf-cli dconf-editor dconf-tools empathy empathy-common eog espeak-data
  evince evolution evolution-common evolution-data-server evolution-data-server-common
  evolution-plugins file-roller finger five-or-more folks-common four-in-a-row gdebi gdm3 gedit
  gedit-common gedit-plugins geoclue geoclue-hostip geoclue-localnet geoclue-manual
  geoclue-nominatim gir1.2-accountsservice-1.0 gir1.2-atspi-2.0 gir1.2-caribou-1.0
  gir1.2-clutter-gst-2.0 gir1.2-evince-3.0 gir1.2-gck-1 gir1.2-gconf-2.0 gir1.2-gcr-3
  gir1.2-gdata-0.0 gir1.2-gdesktopenums-3.0 gir1.2-gdm3 gir1.2-gkbd-3.0 gir1.2-gmenu-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-goa-1.0 gir1.2-gtkclutter-1.0
  gir1.2-gtop-2.0 gir1.2-gucharmap-2.90 gir1.2-ibus-1.0 gir1.2-javascriptcoregtk-3.0
  gir1.2-mutter-3.0 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 gir1.2-panelapplet-4.0
  gir1.2-polkit-1.0 gir1.2-rb-3.0 gir1.2-rest-0.7 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12
  gir1.2-telepathylogger-0.2 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 gir1.2-tracker-0.16
  gir1.2-upowerglib-1.0 gir1.2-vte-2.90 gir1.2-webkit-3.0 gir1.2-wnck-3.0 gir1.2-xkl-1.0
  gir1.2-zpj-0.0 gjs gkbd-capplet gksu gnash gnash-common gnome-applets gnome-applets-data
  gnome-backgrounds gnome-bluetooth gnome-calculator gnome-chess gnome-color-manager
  gnome-contacts gnome-control-center gnome-control-center-data gnome-core gnome-desktop3-data
  gnome-dictionary gnome-disk-utility gnome-documents gnome-font-viewer gnome-games
  gnome-icon-theme-extras gnome-klotski gnome-mag gnome-mahjongg gnome-media gnome-menus
  gnome-mines gnome-nettool gnome-nibbles gnome-online-accounts gnome-orca gnome-packagekit
  gnome-packagekit-data gnome-packagekit-session gnome-panel gnome-panel-data gnome-power-manager
  gnome-robots gnome-screensaver gnome-screenshot gnome-session gnome-session-bin
  gnome-session-common gnome-session-flashback gnome-settings-daemon gnome-shell
  gnome-shell-common gnome-shell-extensions gnome-sudoku gnome-sushi gnome-system-log
  gnome-system-monitor gnome-terminal gnome-terminal-data gnome-tetravex gnome-tweak-tool
  gnome-user-guide gnome-user-share gnome-video-effects gnuchess gnuchess-book gnuplot gnuplot-nox
  gnustep-base-common gnustep-base-runtime gnustep-common grilo-plugins-0.2 groff
  gstreamer0.10-nice gstreamer1.0-clutter gstreamer1.0-libav gstreamer1.0-nice
  gstreamer1.0-plugins-bad gtk2-engines gucharmap guile-2.0-libs hamster-applet hwdata iagno
  iputils-tracepath libaccountsservice0 libapache2-mod-dnssd libatk-adaptor libatspi1.0-0
  libavahi-gobject0 libavahi-ui-gtk3-0 libavresample1 libboost-chrono1.54.0
  libboost-program-options1.54.0 libboost-thread1.54.0 libbrlapi0.6 libcamel-1.2-43
  libcanberra-gtk-module libcanberra-gtk0 libcanberra-pulse libcaribou-common
  libcaribou-gtk-module libcaribou-gtk3-module libcaribou0 libchamplain-0.12-0
  libchamplain-gtk-0.12-0 libcheese-gtk23 libcheese7 libclutter-gst-2.0-0 libclutter-gtk-1.0-0
  libcolorblind0 libcolord-gtk1 libcpufreq0 libcrack2 libdbus-glib2.0-cil libdbus2.0-cil
  libdee-1.0-4 libdmapsharing-3.0-2 libdotconf1.0 libebackend-1.2-6 libebook-1.2-14
  libebook-contacts-1.2-0 libecal-1.2-15 libedata-book-1.2-17 libedata-cal-1.2-20
  libedataserver-1.2-17 libespeak1 libevolution libexempi3 libfarstream-0.1-0 libfarstream-0.2-2
  libfolks-eds25 libfolks-telepathy25 libfolks25 libgail-common libgconf2.0-cil libgdata-common
  libgdata13 libgdict-1.0-6 libgdict-common libgdiplus libgdm1 libgeocode-glib0 libgksu2-0
  libgles2-mesa libglib2.0-cil libgnome-desktop-3-7 libgnome-mag2 libgnome-media-profiles-3.0-0
  libgnome-menu-3-0 libgnomekbd-common libgnomekbd8 libgnustep-base1.22 libgrilo-0.2-1
  libgsf-1-114 libgsf-1-common libgssdp-1.0-3 libgstreamer-plugins-bad1.0-0 libgtk-vnc-2.0-0
  libgtk2.0-cil libgtkglext1 libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0
  libgtkmm-3.0-1 libgtop2-7 libgtop2-common libgucharmap-2-90-7 libgupnp-1.0-4 libgupnp-av-1.0-2
  libgupnp-dlna-2.0-3 libgupnp-igd-1.0-4 libgvnc-1.0-0 libgweather-3-3 libgweather-common
  libibus-1.0-5 libicc2 libidl0 libimdi0 libiptcdata0 libjemalloc1 liblinear-tools liblinear1
  liblouis-data liblouis2 libmeanwhile1 libmetacity-private0a libmission-control-plugins0
  libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo4.0-cil libmono-corlib4.0-cil
  libmono-corlib4.5-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil
  libmono-security4.0-cil libmono-sharpzip4.84-cil libmono-system-configuration4.0-cil
  libmono-system-core4.0-cil libmono-system-drawing4.0-cil libmono-system-security4.0-cil
  libmono-system-xml4.0-cil libmono-system4.0-cil libmpg123-0 libmusicbrainz5-0 libmutter0b
  libnatpmp1 libnice10 liboauth0 libobjc4 libopencv-calib3d2.4 libopencv-contrib2.4
  libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect2.4
  libopencv-video2.4 libopenobex1 liborbit2 libpam-systemd libpanel-applet-4-0 libpst4
  libpulse-mainloop-glib0 libpulsedsp libpurple-bin libpurple0 libpwquality-common libpwquality1
  libreoffice-gnome librest-extras-0.7-0 librhythmbox-core8 librygel-core-2.0-1
  librygel-renderer-2.0-1 librygel-renderer-gst-2.0-1 librygel-server-2.0-1 libsbc1
  libsocialweb-client2 libsocialweb-common libsocialweb-service libsocialweb0
  libsofia-sip-ua-glib3 libsofia-sip-ua0 libsonic0 libsrtp0 libsvm-tools libsystemd-daemon0
  libtbb2 libtelepathy-farstream3 libtelepathy-glib0 libtelepathy-logger3 libtotem0
  libtracker-extract-0.16-0 libtracker-miner-0.16-0 libwacom-common libwacom2
  libwebrtc-audio-processing-0 libwnck-3-0 libwnck-3-common libytnef0 libzapojit-0.0-0
  libzeitgeist-1.0-1 libzeitgeist-2.0-0 libzephyr4 lightsoff media-player-info metacity
  metacity-common mono-4.0-gac mono-gac mono-runtime mousetweaks mutter-common nautilus
  nautilus-data nautilus-sendto nautilus-sendto-empathy nmap obex-data-server obexd-client
  pidgin-data pulseaudio pulseaudio-module-x11 pulseaudio-utils python-brlapi python-gconf
  python-gnome2 python-louis python-mako python-markupsafe python-pyatspi python-pyatspi2
  python-pyorbit python-speechd python-wnck python-zeitgeist quadrapassel rdesktop rhythmbox
  rhythmbox-data rhythmbox-plugin-cdrecorder rhythmbox-plugins rtkit rygel rygel-playbin
  rygel-preferences simple-scan sound-juicer sound-theme-freedesktop speech-dispatcher sudo
  swell-foop systemd tali telepathy-gabble telepathy-haze telepathy-idle telepathy-logger
  telepathy-mission-control-5 telepathy-rakia telepathy-salut tomboy totem totem-common
  totem-plugins tracker tracker-extract tracker-gui tracker-miner-fs tracker-utils
  transmission-common transmission-gtk unar unoconv vinagre vino xbrlapi xdg-user-dirs-gtk
  xserver-xephyr xul-ext-adblock-plus zeitgeist zeitgeist-core zeitgeist-datahub zenity
  zenity-common
Suggested packages:
  gnome-cards-data gir1.2-colordgtk-1.0 doc-base browser-plugin-lightspark
  gnome-video-effects-frei0r evolution-ews evolution-plugins-experimental
  evolution-data-server-dbg arj lha lzip lzop ncompress rpm2cpio rzip sharutils unace unalz zoo
  dia-gnome gnome-boxes gnucash libreoffice-evolution planner iceweasel-l10n-all
  xul-ext-gnome-keyring libcanberra-gtk3-module gnome-hearts gnome-system-tools
  gnome-packagekit-tools xboard eboard scid feedgnuplot gnuplot-doc libgnuplot-iostream-dev
  python-gnuplot gnustep-base-doc frei0r-plugins python-evolution monodoc-gtk2.0-manual
  liblinear-dev libmono-i18n4.0-all libgamin0 natpmp-utils sofia-sip-doc srtp-utils pidgin gajim
  pavumeter pavucontrol paman paprefs python-gnome2-doc python-beaker python-mako-doc pcscd
  gnome-codec-install rygel-tracker rygel-mediathek gstreamer0.10-plugins-ugly gstreamer0.10-lame
  gstreamer0.10-plugins-really-bad speech-dispatcher-festival speech-dispatcher-doc-cs
  libttspico-utils systemd-ui tasque totem-mozilla gromit
The following packages will be REMOVED:
  evince-gtk
The following NEW packages will be installed:
  accountsservice aglfn aisleriot alacarte apg argyll bluez bogofilter bogofilter-bdb
  bogofilter-common browser-plugin-gnash caribou caribou-antler cheese cheese-common cli-common
  cracklib-runtime dconf-cli dconf-editor dconf-tools empathy empathy-common eog espeak-data
  evince evolution evolution-common evolution-data-server evolution-data-server-common
  evolution-plugins file-roller finger five-or-more folks-common four-in-a-row gdebi gdm3 gedit
  gedit-common gedit-plugins geoclue geoclue-hostip geoclue-localnet geoclue-manual
  geoclue-nominatim gir1.2-accountsservice-1.0 gir1.2-atspi-2.0 gir1.2-caribou-1.0
  gir1.2-clutter-gst-2.0 gir1.2-evince-3.0 gir1.2-gck-1 gir1.2-gconf-2.0 gir1.2-gcr-3
  gir1.2-gdata-0.0 gir1.2-gdesktopenums-3.0 gir1.2-gdm3 gir1.2-gkbd-3.0 gir1.2-gmenu-3.0
  gir1.2-gnomebluetooth-1.0 gir1.2-gnomedesktop-3.0 gir1.2-goa-1.0 gir1.2-gtkclutter-1.0
  gir1.2-gtop-2.0 gir1.2-gucharmap-2.90 gir1.2-ibus-1.0 gir1.2-javascriptcoregtk-3.0
  gir1.2-mutter-3.0 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0 gir1.2-panelapplet-4.0
  gir1.2-polkit-1.0 gir1.2-rb-3.0 gir1.2-rest-0.7 gir1.2-soup-2.4 gir1.2-telepathyglib-0.12
  gir1.2-telepathylogger-0.2 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 gir1.2-tracker-0.16
  gir1.2-upowerglib-1.0 gir1.2-vte-2.90 gir1.2-webkit-3.0 gir1.2-wnck-3.0 gir1.2-xkl-1.0
  gir1.2-zpj-0.0 gjs gkbd-capplet gksu gnash gnash-common gnome gnome-applets gnome-applets-data
  gnome-backgrounds gnome-bluetooth gnome-calculator gnome-chess gnome-color-manager
  gnome-contacts gnome-control-center gnome-control-center-data gnome-core gnome-desktop3-data
  gnome-dictionary gnome-disk-utility gnome-documents gnome-font-viewer gnome-games
  gnome-icon-theme-extras gnome-klotski gnome-mag gnome-mahjongg gnome-media gnome-menus
  gnome-mines gnome-nettool gnome-nibbles gnome-online-accounts gnome-orca gnome-packagekit
  gnome-packagekit-data gnome-packagekit-session gnome-panel gnome-panel-data gnome-power-manager
  gnome-robots gnome-screensaver gnome-screenshot gnome-session gnome-session-bin
  gnome-session-common gnome-session-flashback gnome-settings-daemon gnome-shell
  gnome-shell-common gnome-shell-extensions gnome-sudoku gnome-sushi gnome-system-log
  gnome-system-monitor gnome-terminal gnome-terminal-data gnome-tetravex gnome-tweak-tool
  gnome-user-guide gnome-user-share gnome-video-effects gnuchess gnuchess-book gnuplot gnuplot-nox
  gnustep-base-common gnustep-base-runtime gnustep-common grilo-plugins-0.2 groff
  gstreamer0.10-nice gstreamer1.0-clutter gstreamer1.0-libav gstreamer1.0-nice
  gstreamer1.0-plugins-bad gtk2-engines gucharmap guile-2.0-libs hamster-applet hwdata iagno
  iputils-tracepath libaccountsservice0 libapache2-mod-dnssd libatk-adaptor libatspi1.0-0
  libavahi-gobject0 libavahi-ui-gtk3-0 libavresample1 libboost-chrono1.54.0
  libboost-program-options1.54.0 libboost-thread1.54.0 libbrlapi0.6 libcamel-1.2-43
  libcanberra-gtk-module libcanberra-gtk0 libcanberra-pulse libcaribou-common
  libcaribou-gtk-module libcaribou-gtk3-module libcaribou0 libchamplain-0.12-0
  libchamplain-gtk-0.12-0 libcheese-gtk23 libcheese7 libclutter-gst-2.0-0 libclutter-gtk-1.0-0
  libcolorblind0 libcolord-gtk1 libcpufreq0 libcrack2 libdbus-glib2.0-cil libdbus2.0-cil
  libdee-1.0-4 libdmapsharing-3.0-2 libdotconf1.0 libebackend-1.2-6 libebook-1.2-14
  libebook-contacts-1.2-0 libecal-1.2-15 libedata-book-1.2-17 libedata-cal-1.2-20
  libedataserver-1.2-17 libespeak1 libevolution libexempi3 libfarstream-0.1-0 libfarstream-0.2-2
  libfolks-eds25 libfolks-telepathy25 libfolks25 libgail-common libgconf2.0-cil libgdata-common
  libgdata13 libgdict-1.0-6 libgdict-common libgdiplus libgdm1 libgeocode-glib0 libgksu2-0
  libgles2-mesa libglib2.0-cil libgnome-desktop-3-7 libgnome-mag2 libgnome-media-profiles-3.0-0
  libgnome-menu-3-0 libgnomekbd-common libgnomekbd8 libgnustep-base1.22 libgrilo-0.2-1
  libgsf-1-114 libgsf-1-common libgssdp-1.0-3 libgstreamer-plugins-bad1.0-0 libgtk-vnc-2.0-0
  libgtk2.0-cil libgtkglext1 libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0
  libgtkmm-3.0-1 libgtop2-7 libgtop2-common libgucharmap-2-90-7 libgupnp-1.0-4 libgupnp-av-1.0-2
  libgupnp-dlna-2.0-3 libgupnp-igd-1.0-4 libgvnc-1.0-0 libgweather-3-3 libgweather-common
  libibus-1.0-5 libicc2 libidl0 libimdi0 libiptcdata0 libjemalloc1 liblinear-tools liblinear1
  liblouis-data liblouis2 libmeanwhile1 libmetacity-private0a libmission-control-plugins0
  libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-cairo4.0-cil libmono-corlib4.0-cil
  libmono-corlib4.5-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil libmono-posix4.0-cil
  libmono-security4.0-cil libmono-sharpzip4.84-cil libmono-system-configuration4.0-cil
  libmono-system-core4.0-cil libmono-system-drawing4.0-cil libmono-system-security4.0-cil
  libmono-system-xml4.0-cil libmono-system4.0-cil libmpg123-0 libmusicbrainz5-0 libmutter0b
  libnatpmp1 libnice10 liboauth0 libobjc4 libopencv-calib3d2.4 libopencv-contrib2.4
  libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect2.4
  libopencv-video2.4 libopenobex1 liborbit2 libpam-systemd libpanel-applet-4-0 libpst4
  libpulse-mainloop-glib0 libpulsedsp libpurple-bin libpurple0 libpwquality-common libpwquality1
  libreoffice-gnome librest-extras-0.7-0 librhythmbox-core8 librygel-core-2.0-1
  librygel-renderer-2.0-1 librygel-renderer-gst-2.0-1 librygel-server-2.0-1 libsbc1
  libsocialweb-client2 libsocialweb-common libsocialweb-service libsocialweb0
  libsofia-sip-ua-glib3 libsofia-sip-ua0 libsonic0 libsrtp0 libsvm-tools libsystemd-daemon0
  libtbb2 libtelepathy-farstream3 libtelepathy-glib0 libtelepathy-logger3 libtotem0
  libtracker-extract-0.16-0 libtracker-miner-0.16-0 libwacom-common libwacom2
  libwebrtc-audio-processing-0 libwnck-3-0 libwnck-3-common libytnef0 libzapojit-0.0-0
  libzeitgeist-1.0-1 libzeitgeist-2.0-0 libzephyr4 lightsoff media-player-info metacity
  metacity-common mono-4.0-gac mono-gac mono-runtime mousetweaks mutter-common nautilus
  nautilus-data nautilus-sendto nautilus-sendto-empathy nmap obex-data-server obexd-client
  pidgin-data pulseaudio pulseaudio-module-x11 pulseaudio-utils python-brlapi python-gconf
  python-gnome2 python-louis python-mako python-markupsafe python-pyatspi python-pyatspi2
  python-pyorbit python-speechd python-wnck python-zeitgeist quadrapassel rdesktop rhythmbox
  rhythmbox-data rhythmbox-plugin-cdrecorder rhythmbox-plugins rtkit rygel rygel-playbin
  rygel-preferences simple-scan sound-juicer sound-theme-freedesktop speech-dispatcher sudo
  swell-foop systemd tali telepathy-gabble telepathy-haze telepathy-idle telepathy-logger
  telepathy-mission-control-5 telepathy-rakia telepathy-salut tomboy totem totem-common
  totem-plugins tracker tracker-extract tracker-gui tracker-miner-fs tracker-utils
  transmission-common transmission-gtk unar unoconv vinagre vino xbrlapi xdg-user-dirs-gtk
  xserver-xephyr xul-ext-adblock-plus zeitgeist zeitgeist-core zeitgeist-datahub zenity
  zenity-common
0 upgraded, 432 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/259 MB of archives.
After this operation, 891 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

So there are lots of packages...

I would like to be sure to be able to uninstall all these packages after trying gnome for some time. I'm afraid apt-get remove --purge gnome will not remove all previously installed packages (because gnome is a meta-package).

So, what should I do, after installing gnome, to go back on my minimal xfce system (i.e. delete all installed gnome related packages)?

Update : apt-get autoremove does not remove any of the package installed automatically by gnome.

I deleted the gnome meta-package:

 # apt-get remove gnome
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  gnome
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 53.2 kB disk space will be freed.
Do you want to continue? [Y/n] y

And then tried to remove all gnome packages with autoremove

# apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
share|improve this question
2  
apt-get autoremove removes the packages since they were automatically installed and no previously installed package depends on them. In any case you can just copy-paste the list into a file. Then you know if there are any leftovers. –  Marco Jan 25 at 14:47
    
From the Debian FAQ: “[…] it will not get automatically removed by most package management tools.” However, the suggested solution using aptitude also doesn't remove all packages. –  Marco Jan 26 at 20:45

1 Answer 1

up vote 2 down vote accepted
aptitude purge `dpkg --get-selections | grep gnome | cut -f 1`
aptitude -f install
aptitude purge `dpkg --get-selections | grep deinstall | cut -f 1`
aptitude -f install
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.