Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having problems setting up X.org on Gentoo.

At the moment I have kernel 2.6.37-gentoo-r4 installed and have built X against this kernel. I have nouveau drivers installed and they seem to be working correctly, from what I can see in terminal. I have nVIdia GeForce 9500M GS and it should be supported by the driver since it uses the NV84 (G84) core.

When I try to startx, this is what I get:

ZVEZDA ~ # startx
hostname: Unknown host
xauth:  file /root/.serverauth.4316 does not exist


X.Org X Server 1.9.4
Release Date: 2011-02-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-gentoo-r4 x86_64 Gentoo
Current Operating System: Linux ZVEZDA 2.6.37-gentoo-r4 #2 SMP PREEMPT Mon Apr 11 14:00:26 CEST 2011 x86_64
Kernel command line: root=/dev/sda3 nouveau.modeset=1
Build Date: 11 April 2011  02:02:40PM

Current version of pixman: 0.20.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 11 14:13:09 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
resize called 1920 1200
(EE) Logitech USB Receiver: failed to initialize for relative axes.
(EE) SynPS/2 Synaptics TouchPad no synaptics event device found
(EE) Query no Synaptics: 6003C8
(EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"
which: no keychain in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.2)
/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 63: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 59: twm: command not found
xinit: connection to X server lost

waiting for X server to shut down

When I try to configure Xorg, I get:

ZVEZDA Xorg # Xorg -configure

X.Org X Server 1.9.4
Release Date: 2011-02-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.36-gentoo-r5 x86_64 Gentoo
Current Operating System: Linux ZVEZDA 2.6.37-gentoo-r4 #1 SMP PREEMPT Mon Apr 11 13:37:39 CEST 2011 x86_64
Kernel command line: root=/dev/sda3 nouveau.modeset=1
Build Date: 18 March 2011  09:54:54PM

Current version of pixman: 0.20.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 11 14:04:54 2011
List of video drivers:
        nouveau
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) [drm] No DRICreatePCIBusID symbol
Number of created screens does not match number of detected devices.
  Configuration failed.

The log says:

[    47.459] 
X.Org X Server 1.9.4
Release Date: 2011-02-04
[    47.461] X Protocol Version 11, Revision 0
[    47.461] Build Operating System: Linux 2.6.37-gentoo-r4 x86_64 Gentoo
[    47.462] Current Operating System: Linux ZVEZDA 2.6.37-gentoo-r4 #2 SMP PREEMPT Mon Apr 11 14:00:26 CEST 2011 x86_64
[    47.463] Kernel command line: root=/dev/sda3 nouveau.modeset=1
[    47.464] Build Date: 11 April 2011  02:02:40PM
[    47.465]  
[    47.465] Current version of pixman: 0.20.2
[    47.466]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    47.468] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    47.470] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 11 15:58:36 2011
[    47.471] (II) Loader magic: 0x7d5140
[    47.471] (II) Module ABI versions:
[    47.471]    X.Org ANSI C Emulation: 0.4
[    47.471]    X.Org Video Driver: 8.0
[    47.471]    X.Org XInput driver : 11.0
[    47.471]    X.Org Server Extension : 4.0
[    47.472] (--) PCI:*(0:1:0:0) 10de:0405:1025:011e rev 161, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00005000/128
[    47.473] List of video drivers:
[    47.473]    nouveau
[    47.474] (II) LoadModule: "nouveau"
[    47.474] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[    47.474] (II) Module nouveau: vendor="X.Org Foundation"
[    47.474]    compiled for 1.9.4, module version = 0.0.16
[    47.474]    Module class: X.Org Video Driver
[    47.474]    ABI class: X.Org Video Driver, version 8.0
[    47.475] (II) NOUVEAU driver 
[    47.475] (II) NOUVEAU driver for NVIDIA chipset families :
[    47.475]    RIVA TNT    (NV04)
[    47.475]    RIVA TNT2   (NV05)
[    47.475]    GeForce 256 (NV10)
[    47.475]    GeForce 2   (NV11, NV15)
[    47.475]    GeForce 4MX (NV17, NV18)
[    47.475]    GeForce 3   (NV20)
[    47.475]    GeForce 4Ti (NV25, NV28)
[    47.475]    GeForce FX  (NV3x)
[    47.475]    GeForce 6   (NV4x)
[    47.475]    GeForce 7   (G7x)
[    47.475]    GeForce 8   (G8x)
[    47.491] (++) Using config file: "/root/xorg.conf.new"
[    47.491] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    47.492] (==) ServerLayout "X.org Configured"
[    47.492] (**) |-->Screen "Screen0" (0)
[    47.492] (**) |   |-->Monitor "Monitor0"
[    47.492] (**) |   |-->Device "Card0"
[    47.492] (**) |-->Input Device "Mouse0"
[    47.492] (**) |-->Input Device "Keyboard0"
[    47.492] (==) Automatically adding devices
[    47.493] (==) Automatically enabling devices
[    47.493] (**) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/OTF/,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/,
    /usr/share/fonts/75dpi/,
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/OTF/,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi/,
    /usr/share/fonts/75dpi/
[    47.493] (**) ModulePath set to "/usr/lib64/xorg/modules"
[    47.493] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    47.493] (WW) Disabling Mouse0
[    47.493] (WW) Disabling Keyboard0
[    47.493] (EE) [drm] No DRICreatePCIBusID symbol
[    47.493] Number of created screens does not match number of detected devices.
  Configuration failed.

There are some interesting lines in those files, for example this:

    [    47.475] (II) NOUVEAU driver for NVIDIA chipset families :
    [    47.475]    RIVA TNT    (NV04)
    [    47.475]    RIVA TNT2   (NV05)
    [    47.475]    GeForce 256 (NV10)
    [    47.475]    GeForce 2   (NV11, NV15)
    [    47.475]    GeForce 4MX (NV17, NV18)
    [    47.475]    GeForce 3   (NV20)
    [    47.475]    GeForce 4Ti (NV25, NV28)
    [    47.475]    GeForce FX  (NV3x)
    [    47.475]    GeForce 6   (NV4x)
    [    47.475]    GeForce 7   (G7x)
    [    47.475]    GeForce 8   (G8x)

and

    [    47.493] (EE) [drm] No DRICreatePCIBusID symbol
    [    47.493] Number of created screens does not match number of detected devices.
      Configuration failed.

So what am I missing?

share|improve this question
    
Hard To Say, could you post the content of your xorg.conf file(s)? It appears you are running as the 'root' user, is there a reason for this? –  Chris2048 Apr 11 '11 at 15:08
    
@Chris2048 I'm running as root right now because I'm still setting up the system. There is no other special reason. –  AndrejaKo Apr 11 '11 at 16:33
add comment

1 Answer 1

up vote 2 down vote accepted

I also get the No DRICreatePCIBusID symbol error when I try to run X -configure on my system. Thankfully, I didn't really need to run it in order to make X run. These are the files inside my /etc/X11/xorg.conf.d/:

  • 10-evdev.conf
  • 10-monitor.conf
  • 10-quirks.conf
  • 20-nouveau.conf

10-evdev.conf and 10-quirks.conf came with the xorg-server package. 10-monitor.conf contains the config from the ArchWiki's Xorg page, without the Device section, and 20-nouveau.conf from the Nouveau page.

10-monitor.conf:

Section "Monitor"
        Identifier     "VGA-1"
        Option "PreferredMode" "1280x1024"
EndSection

Section "Monitor"
        Identifier     "TV-1"
EndSection

Section "Screen"
        Identifier     "Screen0"
        Device         "NVIDIA Card"
        DefaultDepth    24

        SubSection     "Display"
                Depth       24
        EndSubSection
EndSection

20-nouveau.conf:

Section "Device"
    Identifier    "NVIDIA Card"
    Driver        "nouveau"
EndSection

The following errors tells us that you haven't installed xterm and twm.

/etc/X11/xinit/xinitrc: line 61: xterm: command not found
/etc/X11/xinit/xinitrc: line 63: exec: xterm: not found
/etc/X11/xinit/xinitrc: line 59: twm: command not found

You might want to emerge them or create a ~/.xinitrc file to override the system-wide xinitrc file.

You might want to post the log for when you are trying to run X normally (i.e. startx). The one you posted is the log after trying to run Xorg -configure.

share|improve this answer
    
Is there a list of commonly needed programs I should install? I would usually just emerge x11-base/xorg-x11 and get xterm and friends. –  AndrejaKo Apr 11 '11 at 16:36
    
You might want to install a Desktop Environment like KDE, GNOME, or Xfce. Other common X11 programs are a browser (e.g. Chrom[e|ium], Firefox) The Gentoo Documentation Resources and the Gentoo Wiki are good resources. –  Ramon Marco Navarro Apr 11 '11 at 18:05
    
I already have GNOME installed, but can't start it until I can get Xorg to work. Those two links saved me countless times over the years, but they are sometimes a bit out of date (and they didn't mention that xterm has to be installed by hand now). –  AndrejaKo Apr 11 '11 at 18:11
    
Try creating ~/.xinitrc containing exec ck-launch-session gnome-session, then run startx. –  Ramon Marco Navarro Apr 11 '11 at 18:31
    
Starting GNOME directly somehow solved the problem. –  AndrejaKo Apr 12 '11 at 10:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.