Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I've been trying to install Fedora20 on my external HD, but have run into problems. Somehow I cannot choose the hard disk to install Fedora. Here is what I've done: First, I went and downloaded the .iso file from, then I erased my external HD and partitioned it (this all happened on windows 8). The external HD now has two partitions and some free space that I left alone. Of the initial 500GB, I now have partitioned

  • 1GB to boot Fedora
  • 370GB for general use
  • 128GB left alone, unformatted

Booting Fedora from the ext. HD worked fine. So I tried to install to hard drive. That also works fine until I have to specify where to install Fedora. At this point I am shown the following disks enter image description here which shows my external HD as having 128GB free. But then I check that disk and press 'done', suddenly the following pops up enter image description here with 0B of free space and 0B of reclaimable space?? When I go to 'custom partitioning' and try to automatically set mount points, then I obtain an error message enter image description here

What am I doing wrong? What should I do instead?

share|improve this question
side note: 1GB is way too much for /boot. – strugee Jan 25 '14 at 3:15
@strugee: Good to know! But actually, I'm not talking about the /boot for custom partitioning, but rather the thingy needed for the installation which one can use on e.g. a USB stick instead of burning it on a CD/DVD (don't really know what the proper name for that is). – Sam Jan 25 '14 at 4:59
Oh, so you booted from the external drive - how did you make that bootable? Why not use a usb thumbdrive to put the installer or live-cd on like shown here, then boot from that, once it's booted, use a tool like gparted to recreate the partition table on the external hdd then launch the install. Maybe just leaving the hdd unformatted but repartitioned will do the trick? – Làchus'n'AI Jan 25 '14 at 6:05
What you're doing seems to of been working with F19.… – slm Jan 25 '14 at 6:08
@illuminÉ: I created a small parition and used LiveUSB Creator, then used the "boot from USB/optical drive" (or something like that) option. That worked. For the more conventional way, I would have had to go out and buy a usb thumbdrive first. So I figured I would try without first. But I guess going out and buying one would have been quite a bit faster, in hindsight... ^^ Thanks for the comment. – Sam Jan 25 '14 at 11:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.