Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Does anybody know how to configure wifi on Lenovo ThinkPad s440 on Ubuntu 12.04 LTS? I can't configure it even with LAN. But anyway, wifi is the first thing I need. I can't find any driver for linux. As I see it from (official specs link) Ubuntu uses Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller to establish network. Can anybody suggest a solution? A driver, a way to configure wifi or anything?..

lspci:

00:00.0 Host bridge: Intel Corporation Device 0a04 (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Device 0a16 (rev 09)
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
00:14.0 USB controller: Intel Corporation Device 9c31 (rev 04)
00:16.0 Communication controller: Intel Corporation Device 9c3a (rev 04)
00:1b.0 Audio device: Intel Corporation Device 9c20 (rev 04)
00:1c.0 PCI bridge: Intel Corporation Device 9c10 (rev e4)
00:1c.1 PCI bridge: Intel Corporation Device 9c12 (rev e4)
00:1c.2 PCI bridge: Intel Corporation Device 9c14 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Device 9c16 (rev e4)
00:1c.4 PCI bridge: Intel Corporation Device 9c18 (rev e4)
00:1d.0 USB controller: Intel Corporation Device 9c26 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Device 9c43 (rev 04)
00:1f.2 SATA controller: Intel Corporation Device 9c03 (rev 04)
00:1f.3 SMBus: Intel Corporation Device 9c22 (rev 04)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 10)
04:00.0 Network controller: Intel Corporation Device 08b2 (rev 73)
05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5227 (rev 01)
06:00.0 Display controller: Advanced Micro Devices [AMD] nee ATI Device 6660
share|improve this question
    
could you post the output of lspci? –  bersch Jan 24 at 23:13
    
Sure! Edited the post. –  boldnik Jan 24 at 23:19
1  
you need to load the iwlwifi kernel module for wifi, just add iwlwifi to /etc/modules . then run modprobe iwlwifi; you'll see your new device with ifconfig -a. Your wifi hardware is Intel 7260. In some cases you need also the firmware, if the module wont load. See also your dmesg output. –  bersch Jan 24 at 23:52
    
Your ethernet (lan) module seems to be r8169, try to follow like explained before. –  bersch Jan 25 at 0:14
    
Thanks a lot! Really helpful info. I will try this out because LTS version is prefered over 3-months support. –  boldnik Jan 25 at 0:20

1 Answer 1

Tried install Ubuntu 13.10. It worked. Not the way I actually wanted to setup the wireless, but it worked. Solution found here

Unfortunately, 13.10 didn't recognize my video card and couldn't load graphics. So, I finally found solution and reposted it here

So, steps (by chili555) are: """ I suggest you download this to your desktop: http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.11-rc3/backports-3.11-rc3-1.tar.bz2 Right-click it and select 'Extract Here.' Now open a terminal and do:

cd Desktop/backports-3.11-rc3-1/
make defconfig-iwlwifi
make
sudo make install

Now download the required firmware here: https://dl.dropboxusercontent.com/u/58267392/iwlwifi-7260-7.ucode.zip Please download it to your desktop. Right-click and select 'Extract Here.' Now open a terminal and do:

sudo cp Desktop/iwlwifi-7260-7.ucode /lib/firmware/
sudo modprobe -r iwldvm  <--If it is not loaded, OK, please proceed
sudo modprobe -r iwlwifi <--If it is not loaded, OK, please proceed
sudo modprobe iwlwifi

Your wireless should now be working. """ Thanks!

share|improve this answer
1  
So what are the steps you did? –  bersch Jan 25 at 0:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.