Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I ran across an issue with ssh after fresh Ubuntu 13.10 installation on Lenovo T420. I tried git pull (which failed) and this led me to more general ssh failing.

After spending some 2-3 hrs of beautiful Sunday morning I have established:

  1. ssh is able to authenticate. see the log below. Also telnet 80 hangs on connecting.
  2. I can connect using putty - it shows motd and prompt
  3. It doesn't work on both wired and wireless connections, also I tried cellular network.
  4. I can successfully login to localhost

here be the log:

debug1: Authentication succeeded (keyboard-interactive).
Authenticated to (via proxy).
debug1: channel 0: new [client-session]
debug1: Requesting
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LC_PAPER = pl_PL.UTF-8

and then just keeps sending

debug1: client_input_channel_req: channel 0 rtype reply 1

without showing me the prompt and eventually disconnects.

I found out that telnet 80 hangs on Connecting <IP-addr>... as well.

share|improve this question
Have you checked /var/log/auth.log on the server for possible error messages? – Martin von Wittich Jan 27 '14 at 19:47
Permission denied. as expected. this is not my machine. – Maciej Jankowski Jan 27 '14 at 21:49
Hmm... is it possible that the server is somehow misconfigured? I'm not really sure how to debug this further. You could check the output of ssh -vvv if there's anything more interesting in the debug messages, but the client side log was rarely helpful for me when debugging issues like these. – Martin von Wittich Jan 27 '14 at 22:35

1 Answer 1

Okay, this on turned out to be WTF LOL squared...

I got a hint that it was most likely ICMP packets being filtered by the firewall. So when you stumble upon this issue check it out.

In the article I found on Hacker News one reads:

ssh did not work. It would connect, flip some data back and forth (as shown with -v) and then would hang.

Certain websites would become inaccessible.

Which were my symptomps that appeared after switching my wireless router to another device.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.